Freedom stops

Hi, I am testing this Freedom free trial. And it has turned protection off alone. Twice.

Is it normal?

I think it should be up and running until asked to switch off.

Or has it something to do with trial ending notification ?

 

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Lithium,

     

    Trial period is 7 days, after which  you have two auto-renewing subscription options:

    -monthly

    -Yearly

     

    Subscriptions can be purchased through either google play or app-store.

     

    Could you precise which Operating system and version you are running Freedome on?

  • lithiumlithium Posts: 3

    Jep...I am using Android 4.3 with Xperia SP

     

    I was planning to order Freedom, but I need to know that it will be working all the time. Not just sometimes..

  • BayaniBayani Posts: 58

    Hi @Ben 

     

    Did you see Lithium's answer?

    Can you help, please?

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Lithium,

     

    In order to troubleshoot your issue, we would need some more precision.

     

    Could it be possible that you were at the end of your trial period when the problem occured?

     

    Were you on the user interface when freedome seemed to switched off or using some other application?

    Can you reproduce the issue and provide here the exact steps needed?

     

    Could you provide the list of application on your device? Do you happen to have another VPN application installed?

     

    Thank you in advance.

     

  • rhapekrhapek Posts: 1

    Hello,

    Yesterday, I installed trial Freedome on iphone 5, OS version 7.1.1 (11D201). It turned on fine and showed the VPN icon on top.

    Today, when I tired to connect to a wifi at a business spot, the wifi asked to accept a certificate. When I accepted, wifi connection initiated normally.

    However, the Freedome VPN turned off at the same time without warning. When I went into the app, it continually tried connecting, and failed. Then, the app suggested that I reinstall the profile. I did that. Same result: VPN cannot connect. IU tried multiple times, same result.

    When I turned OFF wifi on the iphone, Freedome immediately connected and VPN icon reappeared.

     

    I would like to purchase this, but if this is a default behaviour, I won't like it.

     

    When a VPN turns off, I would like it to:

     

    1: let me know that it turned off via alert.

    2: be asked if I want it to turn off.

     

    Can you please look into this?

     

    Thanks.

  • ChrissyChrissy Posts: 438
    Hi rhapek!

    Just looking back through unresolved posts, and noticed that this one never good a response. Have you managed to get this working properly on your own, or do you still need some help?
This discussion has been closed.