"is not a valid win32 application"

So i downloaded the F-Secure startup download (if it makes any difference i am with virgin media) and yet when i open the download it returns a message saying:

 

...is not a valid win32 application

 

any help on what this means and how it can be solved?

 

many thanks

Comments

  • NikKNikK Posts: 931

    The download may have got corrupt, or you downloaded a version not for Windows. Try again from the SAFE Portal 

    If it still doesn't work, try from another browser.

    If you're running XP you could also try right-click the file and select Properties and click Unblock if there's such a button.

    If nothing works, what is the file size of the downloaded file?

    Give Kudos to say "thanks". Click "Accept as Solution" to inform others when your issue's been solved

    Need more help? Submit a Support Request or chat with or call F-Secure support. Or try the User Guides

  • it says the file size is 0 bytes...,

    Spoiler
     

     

     

  • NikKNikK Posts: 931

    What browser do you have and did you try from another browser? What Windows version?

     

    Test another download as a reference, right click this link and save the file. Then check its file size:

    https://download.sp.f-secure.com/tools/F-SecureOnlineScanner.exe

     

     

     

This discussion has been closed.