Issue with Cisco Anyconnect and F-Secure 2014

Ever since the F-Secure 2014 update yesterday I've been unable to access the Cisco Anyconnect VPN through which I do my work.  The error message I've been getting is "Login Denied.  You must have antivirus software active and running."  I contacted the VPN help desk yesterday and today, but I'm not sure how high the priority of my request is.  My question:  Is there anything I can do to resolve this issue?  I read the article about "Allowing Cisco VPN to create a connection," but that fix doesn't work for me as I don't have the "vsdatant" program on my computer.  I'd like to get this resolved, as I'm paid by production and when I'm not working I'm not being paid.  Thanks.


  • NikK
    NikK Posts: 903 Forum Champion

    I think you should contact support and attach an FSDIAG file to it. Do you have a Home or Business F-Secure version? Don't know if it's important to use the right channel or not, but here they are:






    The FSDIAG file contains information that can be used for troubleshooting and solving problems specific to your computer.



  • I contacted F-Secure and put in a ticket.  The thing that got me was that the VPN help desk that deals with the programs I use for my work more or less told me it was my problem and they couldn't help  So, since my co-workers needed my help as the work was piling up rapidly, I took my boss' suggestion and got a trial membership of McAfee, and was in turn able to access the programs I needed.  The contract officer told me that the people running the VPN that used the Cisco Anyconnect were behind in doing their updates, and they were supposed to do them this weekend.  So, time will tell.  I don't like having McAfee on my computer, as I consider it an inferior product, but if I have to have it in order to do my work I'll have to live with it until the VPN people get their act together and do their updates.  


    Thanks for your help. 

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hello Procyon,


    Could you, please, clarify, what do you mean by F-Secure 2014? Is it Internet Security?


    Best regards,


  • YT
    YT Posts: 5

    I have the same problem.


    I bought F-Secure Internet Security in November 2013, and was able to connect to my office PC via Cisco AnyConnect Secure Mobility Client for a few months with no problem.  But since February 14 - the same day when two F-Secure updates were installed - I get a login denied error.


    I sent my question to F-Secure on February 15 attaching the fsdiag but have not heard anything (#00129190)!


    My IT office said it might be the latest F-Secure updates have not been registered with Cisco yet.  I sent them the "About" F-Secure information, and they contacted Cisco.  After a few days they told me that it should be OK.  However, I still cannot get on. 


    It has been10 days now, and I really need a solution.



  • As I said above, I ended up having to get a McAfee account in order to do my job.  I've found the VA's VPN help desk to be anything but helpful.  You might have to do the same. 

  • Yes, it is Internet Security.

  • Popeye
    Popeye Posts: 6 Explorer

    Have any of you tried to reinstall the Cisco AnyConnect VPN client after the F-Secure upgrade?


    We saw this problem ourselves a few years back, and traced the problem to a firewall conflict, as both F-Secure and the AnyConnect client has an integrated firewall. If there is an active policy on the Cisco VPN Concentrator / Cisco ASA that does a firewall check on the client when you connect, this check could fail if F-Secure was installed after the AnyConnect client. The F-Secure installation tampered with the AnyConnect firewall component (I guess this is the "Uninstall conflicting software" setting) when you create an F-Secure installation package.


    Installing F-Secure first and then the AnyConnect client solved the problem for us. The F-Secure upgrade you all describe could have messed with the AnyConnect firewall (or some other setting). Try to reinstall the AnyConnect client and see if that solves your problem (by resetting/reinstalling features in the AnyConnect client).


    It could also be that an antivirus policy on the Cisco VPN Concentrator/ Cisco ASA does not recognize the newest version of F-Secure, thus refusing the connection.

  • I thought about that, but when I asked my boss about reinstalling Cisco Anyconnect she told me she didn't have any way for me to do this, because the person who did the remote installation no longer works there and she doesn't have a copy of the software.  I couldn't believe it - talk about a distaster waiting to happen.  It's not so bad for those who are local to the company, as they can go in in person, but I'm clear across the U.S. and if I lose my programs, e.g. if a meteor falls through my roof and takes out my home office, or my computer explodes after one too many angsty posts from my cousin on Facebook, I'm stuck.


    While I'm on the subject, any suggestions as to what I can do about the fact that I can't get a backup of my programs through my office?  I've done complete backups through F-Secure (and I do mean complete, the ones that take two DVDs)  - does this have the programs on it? 

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    @Procyon @NikK @Popeye @YT


    Hi all!  I've moved this thread to the Home Security board, as it deals with Internet Security 2014.  This should make it easier for our experts to find and respond to the posts.




    // Chrissy

  • NikK
    NikK Posts: 903 Forum Champion

    @Procyon wrote:

    I've done complete backups through F-Secure (and I do mean complete, the ones that take two DVDs)  - does this have the programs on it? 

    If you mean Online Backup, that has a separate board where you can ask questions about it.

    I don't know Online Backup but I think your best option is if you could find a copy of the installation/setup file for the Cisco program.

  • YT
    YT Posts: 5

    I tried uninstalling Cisco AnyConnect VPN client and re-installing it (version 3.1.04066, which I installed in December 2013).  I still get the "login denied" message.

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    HI YT,


    You mentioned " since February 14 - the same day when two F-Secure updates were installed " .

    In order to better understand could you provide more details on that part?


    Did you mean software updates or virus definitions?


    Could you also provide an fsdiag on your support ticket, so that we can investigate your problem.


    Thank you.


  • YT
    YT Posts: 5

    I did - or I thought I did - attach the fsdiag with the ticket:

    Number: 00129190
    Created: 2014-02-15
    Subject: Problem with running Cisco AnyConnect Mobility Client


    If not, I can resend it.


    I am sad that I finally had to uninstall F-Secure and replace it with an inferior product so that I could connect to my office PC.


    I hope someone will find a solution to this problem soon and that F-Secure will let customers like me know.



  • JohannesL
    JohannesL Posts: 38 Former F-Secure Employee

    @Ben @YT


    It has gone 4 weeks since the last post on this topic:


    YT have this issue been solved or is the problem still there?

    Ben have you seen or heard anything new about this case?



  • YT
    YT Posts: 5

    I had to uninstall F-Secure in order to use Cisco AnyConnect client.  I informed F-Secure by email and requested them to inform me (if possible) if this issue ever get resolved.

    It is a pity.  I really like the product.

  • JoniW
    JoniW Posts: 9 Explorer

    Hi YT,


    Do you have case id about your contact to our support ? I can check this with case id.


  • YT
    YT Posts: 5

    Hi Joni,


    The case number is 00129190.

    AWCSDT Posts: 2
    I have the Business version 11.50 client and have had nothing but trouble with VPN connections. We do VPN connections to clients all day and since adding F-Secure in, they don't work at all or are extremely slow. Will be un-installing this.
  • Frisjo
    Frisjo Posts: 47 Enthusiast

    Have you tried using the firewall profile called "Mobile"?, This should have all rules required for encrypted communications.

This discussion has been closed.
Pricing & Product Info