Re: F-Secure constantly installing the same update.

SimonSimon Posts: 2,610 Superuser
If this has been going on for months, this would seem an unlikely cause, but it might just be worth checking that all your Windows Updates are up to date.

Comments

  • jdavejdave Posts: 4

    Windows 7 Ultimate SP1. 

    F-Secure 2.01 build 123


    CCF CUIF 10.02 build 305
    CCF DAAS2 1.10 build 369
    CCF Automatic Update Agent 1.06 build 109
    CCF Upstream 2.01 build 283
    CCF Diagnostics 8.01 build 273
    CCF Scanning 1.39 build 101.166
    CCF Network 1.02 build 134
    CCF Reputation 1.1 build 25.2280

     

    F-Secure puts up a box saying an update is available.  I click ok and give it admin authorization to install.  It seems to install without issue and asks for a reboot.  After reboot the same box pops up again asking for an update.  This has gone on for months.  Sometimes it will stop for a while, then it starts again.

  • NikKNikK Posts: 931

    You're not in the Beta program are you? I have version 1.99 build 192 which I at least think is the latest version of Internet Security 2014 (Release 2 from December 2013) Maybe there's a difference for 32- and 64-bit, don't know.

     

    Anyway, it sounds as the update isn't installed correctly. You can verify this by right-clicking the F-Secure icon in the systray and then select "Open common settings". Any updates NOT installed are shown in bold:

    CommonSettings.png

     

    There are no not-installed in this example.

    You can also download the latest version from here:

    http://www.f-secure.com/en/web/home_global/support/installers

    (as mentioned on this page: don't use this if you have an ISP version or F-Secure SAFE)

    Give Kudos to say "thanks". Click "Accept as Solution" to inform others when your issue's been solved
    Need more help? Submit a Support Request or chat / call F-Secure support
  • jdavejdave Posts: 4

    I have build 123, perhaps there is a difference for 32 amd 64, I have 32,. forgot to mention that before.  I checked as you suggested, nothing is marked as not installed.  But, the box hasn't come back up again either.  Could this be a problem with Windows 7 file access permissions?  I would think it would register some kind of error if that were the case.  It seems significant to me that everything appears fine until the reboot, perhaps something is being blocked by file permissions being reset at reboot? 

  • NikKNikK Posts: 931

    I also have Win 7, 32-bit, still there's a difference:

    You: F-Secure 2.01 build 123

    Me:  F-Secure 1.99 build 192

     

    If the problem persists try installing from the installers page instead. If I try that I get a message saying:

    UpgradeTool.png

    That makes me curious of how you could have a later version number (2.01 vs 1.99) Maybe F-Secure can answer that?

    Also as Simon suggested, check for pending Windows Updates as they can block F-Secure from installing.

    I can't think of anything else at the moment that would cause this behavior at reboot, but you could check the Windows Logs in Event Viewer for any install/reboot errors.

     

    Or you can submit a Support Request and attach an FSDIAG file to it so the support technicians can take a look at your log files.

  • BlackcatBlackcat Posts: 511

    @ jdave,

     

    F-Secure 2.01 build 123 is a beta version of F-Secure.

     

    Common problems for not being able to upgrade include;

     

    1. Installation or upgrade of Computer Security or Online Safety may fail, if Windows update is installing updates at the same time.

     

    2. Upgrade will not start if there is not enough disk space.

     

    3. Has your beta subscription key expired?  Hit "Check now"

     

    Can you check the above suggestions. 

  • jdavejdave Posts: 4

    Windows was not installing updates, subscription is valid, nothing is listed as uninstalled or failed.  When I click the  check for updates link the program says it is up to date, then two seconds later the box pops up offering me an update.  If I don't manually check it pops up a nag box every day at some point.  I tried doing the install from the admin desktop as well. 

  • jdavejdave Posts: 4

    Thanks for the help, I'll try installing manually.  If that doesn't work, or if it does I'll contact F-Secure as you suggested.  After all, that's why we have betas, right?

  • BenBen Posts: 2,640 F-Secure Product Expert

    Hello Jdave, 

     

    I moved the thread to the more appropriate board.

    If you contact us be sure to use the Beta channel.

     

    Cheers

  • BlackcatBlackcat Posts: 511

    @jdave 

     

    You are running an old beta; the latest version is 2.05.

     

    SnapCrab_NoName_2014-2-17_8-36-36_No-00.png

     

    So you could also try uninstalling and installing the latest beta to see whether your problem persists.

     

     

    Edit; @Ben 

     

    sequence of posts has changed after thread moved; Simon is now the thread starter!

  • BenBen Posts: 2,640 F-Secure Product Expert

    @Blackcat,

     

    Yes I also noticed that. I am currently checking how to correct it and sort the post properly.

    Thanks for reporting :)

     

This discussion has been closed.