F Secure Setup fails at License Terms screen with "Download Failed"

I am trying to install the Virgin Media F Secure software on my XP PC service pack 3.  When I run the VirginMediaNetworkInstaller_C-XXXXX-XXXXX-XXXXX-UHHPP.exe file it fails almost straight away with an error "Download Failed. Check that your network connection is working and try again."


Internet connection is working fine both on Internet Explorer and on Firefox.  It must be, to have downloaded the the installer in the first place.


I have uninstalled all Virgin Media software, using the "UninstallationTool.exe" and with Control Panel.


My PC is a Quad Core Q6600 with 1.5TB drives, XP 32 bit.


I have tried turning of the firewall and turning off non essestial programs.


This is very fustrating.


I had no problems on with a Win 8 laptop.


Can you help ?


Mod Edit: Removed personal subscription information.

Best Answer

  • JohannesLJohannesL Posts: 43
    Accepted Answer

    Hi, SC!


    Im sorry to hear that you dont have been given answer on your questions.


    Even though the Microsoft Xp support have finished, you're still able to download updates that have already been released before the ending of the support.


    A reset on your 12 month trial key are only possible through the support so please try to fil out the following support request form yet again and see if it helps.




  • SimonSimon Posts: 2,600 Superuser

    Firstly, you may wish to edit your post, as you should not have revealed your license key, assuming that's what's included in the installer .exe file.  Smiley Wink


    To be honest, I'm not 100% certain that you're trying to run the correct installer, as I would have thought it should have been F-SecureNetworkInstaller_xxx.exe, but I'm not sure what the link from the Virgin portal looks like.


    You might find it useful to read this thread on how to remove VMS and install F-Secure SAFE from the SAFE Portal. It will contain the link to the Virgin Media Removal Tool which it might be worth running again if you still encounter problems.


    Come back to us if you need further help.  :)

  • NikKNikK Posts: 931

    In addition to Simons advice, you could try logging in to the SAFE Portal from your Win 8 PC, click install, then click "Another Device" and follow the instructions.

  • VilleVille Posts: 489 F-Secure Employee



    You might not have up-to-date list of root certificates on your Windows XP computer. You could try installing them from Windows update or directly from http://www.microsoft.com/en-us/download/details.aspx?id=38918.


    From Vista onwards, Windows has been able to update certificates automatically, so that's why Windows 8 would work.



    (F-Secure R&D)


  • SCSC Posts: 20

    I've tried all the tips in your post and in the other posts but still no luck.

     Has this been tested on XP do you know ?

    And is there anything else I could try ?



  • NikKNikK Posts: 931

    It guess it's a browser issue. Internet Explorer 8 is an old but the latest supported version on XP, so I suggest you try the SAFE Portal with Firefox if you haven't tried that already.


    System Requirements for SAFE and XP

    Windows XP Home Edition*

    Windows XP Professional*

    Windows XP Media Center Edition*

    *32-bit, Service Pack 3 or later


    Internet Security

    Processor: Intel Pentium 4 or equivalent

    Memory requirements: 1 GB or more

    Disk Space: 800 MB free disk space

    High speed Internet connection to validate your subscription and receive updates

    The system must fulfill Windows minimum requirements as specified by Microsoft

  • SCSC Posts: 20



    I don't think it can be a browser issue as I easly downloaded the install exe file.  The problem occurs when I run the install exe file named in my first post.  It starts up, asks me to select the language, I then click the install button and then the error box appears "Download failed. Check that your network connection is working and try again".


    But thanks for looking at this issue.

  • NikKNikK Posts: 931

    I see. I've seen that in the OnlineScanner, but that's because I have control of all outbound network connections and I don't allow them by default. However, the Windows Firewall in XP has no outbound firewall control, only inbound.

    Do you have any other security products installed that could block connections?


    Besides that I can only think of settings in Internet Explorer that might be used when an application tries to connect to Internet.

    I suggest you go into settings in Internet Explorer and reset the Security Levels to the Default Level.

  • NikKNikK Posts: 931

    The OnlineScanner is just another F-Secure exe file that also connects to internet. Here are known issues and limitations for XP. Maybe they can be of help?


    2. Windows XP: Online Scanner must be run under an Administrator account
    On Windows XP, Online Scanner must always be run under an Administrator account. It needs admin privileges to scan system memory and files.

    3. Internet Explorer (IE) 7 and 8: Online Scanner doesn't start when Internet and Local intranet security levels are set to High
    The Online Scanner user interface uses the functionality of an Internet Explorer Server object. To allow Online Scanner to operate, you must set IE settings to default:

    • In the browser go to Tools > Internet options.
    • Select the Security tab.
    • Set Internet and Local intranet security levels to Medium.

    4. IE7 and 8: Online Scanner doesn't start in "offline" mode
    IE should be in its normal, "online" mode, otherwise Online Scanner cannot run.

  • SCSC Posts: 20

    I can download and run OnlineScanner with no problems.

    There are no other security programs running.

    Internet security was set to the default levels, but I reset them anyway.


    Problem is still there.


    Has this been tested with Xp do you know ?


  • SCSC Posts: 20

    I also tried using the F-SecureNetworkInstallerUpg.exe file and get the same error :-(



  • NikKNikK Posts: 931

    I'm sure it's been tested as it's mentioned with specific requirements for XP and SAFE. And I know other Virgin Media customers running XP have had problems installing, but after running the specific VMS Removal Tool the problem was resolved. The link to it was posted by Simon in the first reply in this thread so I assume you've run it?


    I'm out of ideas for the moment so I suggest you submit a Support Request and attach an FSDIAG file to it. That'll provide the support technicians with log files and vital information about your PC.

    You should mention that running the OnlineScanner works and include a link to this thread.


    PS. Since you're unable to install the product you have to download the zip file mentioned in the FSDIAG page.

  • NikKNikK Posts: 931

    @SC wrote:

    I also tried using the F-SecureNetworkInstallerUpg.exe file and get the same error :-(

    For SAFE you have to download from the SAFE Portal and not from the Downloads page.

  • VilleVille Posts: 489 F-Secure Employee



    You can see the reason for the download failure from log file at c:\documents and settings\all users\application data\f-secure\logs\ccf\downloaded_files.log.


    To see the "application data" folder, you need to open Windows (file) Explorer > "Tools" > "Folder Options" and select "Show hidden files and folders" in "View" tab.



    (F-Secure R&D)


  • NikKNikK Posts: 931

    @Ville Is there a log in newer Windows versions too? I tried searching but no luck.

  • VilleVille Posts: 489 F-Secure Employee

    @NikK Yes, it's under c:\ProgramData\F-Secure\Logs\CCF.


    In general I would advice to not read the logs. They contain a lot of information that is meant for support and developers and is not understandable to users.



    (F-Secure R&D)


  • NikKNikK Posts: 931

    Thanks @Ville  Much appreciated!


    I understand the general advice. In my case I'm a developer and the type that's interested in reading about what encryption algorithm, cipher mode, KDF, hash functions and iterations are used in Key Smiley Wink


    Could you give me a hint what log records adding sites to browsing protection? (if any)

    I have a unique problem that even support can't answer. Unknown sites added and I've never added any myself. I suspect DeepGuard may be involved when detecting connections and I allow it, but I'm told that's not possible, so I'm stuck troubleshooting.

  • VilleVille Posts: 489 F-Secure Employee



    We don't log in default logging level any personal information. Web sites (and therefore browsing history) are personal information and not logged.



    (F-Secure R&D)


  • NikKNikK Posts: 931

    @Ville Ok. Well if you can think of anything that could help me troubleshoot this I'd appreciate it. I'm 100% sure I've never added any site in Browsing Protection nor through Banking Protection.

  • SCSC Posts: 20


    I looked at the "downloaded_files.log" and it is full of entries like this:


    2014-01-30 20:46:25.168 [03a0.0d58] .W: (FILE) FileAccess 'https://666.spi.f-secure.com:443/packaging/services/spi/stubconfiguration?operatorId=666&version=55' -> 'E:\Documents and Settings\All Users\Application Data\F-Secure\MySA\Downloads\stubconf.xml'Smiley Sad0 retries) [HTTP 0][Win32 2148073480] in 266ms (0 bytes -> 0kB/s)
    2014-01-30 20:46:25.653 [03a0.0d58] .W: (FILE) FileAccess 'https://666.spi.f-secure.com:443/packaging/services/spi/stubconfiguration?operatorId=666&version=55' -> 'E:\Documents and Settings\All Users\Application Data\F-Secure\MySA\Downloads\stubconf.xml'Smiley Sad0 retries) [HTTP 0][Win32 2148073480] in 250ms (0 bytes -> 0kB/s)
    2014-01-30 20:46:26.152 [03a0.0d58] .W: (FILE) FileAccess 'https://666.spi.f-secure.com:443/packaging/services/spi/stubconfiguration?operatorId=666&version=55' -> 'E:\Documents and Settings\All Users\Application Data\F-Secure\MySA\Downloads\stubconf.xml'Smiley Sad0 retries) [HTTP 0][Win32 2148073480] in 250ms (0 bytes -> 0kB/s)


    I can't see ' the reason" from this, please help



  • SCSC Posts: 20

    Is it because my boot drive is drive "E" ?


  • NikKNikK Posts: 931

    My guess is that this file can't be downloaded cause it says 0 bytes as size. I tried and I can access it, it's an XML file. Can you?


    Don't try with the link you pasted because it has a ' in the end that messes it up.


    I have no idea about E: but it sounds unlikely that an F-Secure product would only work on C:


    Since it's weekend now it might take until next week for someone from F-Secure to answer.

    If you haven't followed my advice to send a support request with an FSDIAG file, I suggest you do that. Then wait and see if you get an answer from support or here first. You double your chances Smiley Wink


  • SCSC Posts: 20


    The link you provided comes up with a textural view of html, first few lines :-


    <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    - <response>
    Sbut no program runs, should it ?
    AAlso I did follow your advice and send the diag log zip to thehelp desk.
    TThanks for looking at this for me, by the way.
  • NikKNikK Posts: 931

    It's a text file so that's how it should look. So no problem accessing it then, at least not from the browser.


    You're welcome. But now I think we have to wait for the professionals to help out :)

  • VilleVille Posts: 489 F-Secure Employee



    Interesting errors there. I have never seen that kind of problem before (and I have written that part of the code myself). It looks like it's a problem with crypto library verifying the SSL connection. I think support will have to continue from here on.



    E: drive is not a problem.



    (F-Secure R&D)


  • SCSC Posts: 20



    I've had not much luck with support.  They asked me to make Internet Explorer as default browser and reset my Internet Options Settings. And to flush DNS and ensure there were no hardcode in TCP/IP settings.


    Yet none of this worked. The fact that I can download and run OnlineScanner with no problems seems to have been ignored and I wonder if i am just getting their regular reply.


    Please can anyone help ???



  • SimonSimon Posts: 2,600 Superuser

    I've just read through the thread again, and I can't see anywhere that you've tried another browser.  It may seem an unlikely cause of the problem, but can you try in Firefox or Chrome, just for elimination purposes, if nothing else?


    Secondly, although it's never been installed, it still won't do any harm to run the F-Secure Uninstallation Tool, just to start again with a clean slate, so to speak.


    I know this is clutching at straws, but anything is probably worth a try at this stage, as there doesn't seem to be any other progress in diagnosing the problem.  dunno.gif

  • NikKNikK Posts: 931

    Simon, it's not the download that's the problem. It's when configuration files are to be downloaded during the installation process. Internet Explorer is partly integrated in Windows compared to other browsers and that's why its settings may have something to do with this. In XP for example the only way to run Windows Update is with Internet Explorer.

    Anyway, the advice on the Uninstallation Tool could be worth a try.


    If you haven't deleted browsing history, temporary files, cookies etc you should try that as well.


    I think the difference with OnlineScanner is that it doesn't download any configuration files over SSL, as in this case.


    Check if you have any windows updates(including optional updates) for the .NET Framework


    @Ville as a workaround, is there any way these config files can be downloaded manually and tell the installer to don't download them?

  • SCSC Posts: 20

    Hi Guys,


    Thanks for the replies, but still no luck.


    I've run again the installation file, cleared history etc etc.  This is the last ".NET framework" update which was Sept 2013 :-


     Microsoft .NET Framework 4 on XP, Server 2003, Vista, Windows 7, Server 2008 x86 (KB2835393)


    There must be a difference in the OnlineScanner and F - secure download that is causing this issue.


    Has this ever been tested on XP ?


    Thanks again.

  • kvickkvick Posts: 2



    >I've had not much luck with support.  They asked me to make Internet Explorer as default browser and reset my Internet >Options Settings. And to flush DNS and ensure there were no hardcode in TCP/IP settings.


    If you have submitted a support case, could you share the SR ID? So we could check the case.



  • SCSC Posts: 20



    The ID ref is 00118221



This discussion has been closed.