Fritz!Box 7390

Hi, after installing F-Secure 2014 on Windows 7 x64, I could no longer log-in to my Fritz!Box 7390. Status in browser remains: Connecting... After 5 minutes I get the Fritz!Box Welcome Screen, but WITHOUT the password prompt. So far, the only way to connect to Fritz!Box is by *disabling* Advanced network protection: UNcheck [-] Do not allow applications to download harmfull files.


  • solidstate
    solidstate Posts: 4 New Member

    Thank You,


    yes, there are some clues in the german thread, but these are all bypsees to the problem and not a real solution. I have tried them all and some of them work temporarily. However after a clean boot the problem is there again. The only way to reacht the Fritz!Box is to lower the security level. Meanwhile I have removed F-Secure and replaced it with Comodo. The problem is no longer there (Comodo also removed 19 security issues that F-Secure did not detect).

  • Jake
    Jake Posts: 74 Former F-Secure Employee

    Hi solidstate,


    Our R&D is currently investigating this issue.

  • solidstate
    solidstate Posts: 4 New Member

    Hi Jake,


    I hope you can solve the problem, so I can re-install F-Secure. If there is anything I can do the help you solve the problem, please let me know.


    regards, Solid State.

  • solidstate
    solidstate Posts: 4 New Member



    does anybody know if the Fritz!Box login problem has been solved? I checked the german thread and there seems to be some progress, but I still cannot find a final solution to this probelm.



This discussion has been closed.
Pricing & Product Info