Can't see inside protected folders

I've installed F-Secure for the second time now and have the same problem that caused me to uninstall it before, F-Secure cannot seem to see inside user folders. This makes it virtually useless because that's where all the viruses tend to be. For example, if I slave a Windows hard drive to my computer and try to scan F:\Users\, no files are scanned because no files are found. Similarly, if I'm logged on as "User A" and try to scan C:\Users\User B, no files are scanned and no files are seen. No other AV that I've tested on this platform has this problem, ESET, G-Data, Bullguard, Avira, Avast, BitDefender, Malwarebytes, Webroot, none of them have this problem, it is unique to F-Secure. I don't get the impression that tech support is able to even understand the problem, am hoping someone here has solved this or at least has a clue.


  • Ville
    Ville Posts: 672 F-Secure Product Expert



    If you launch the scan from explorer right-click context menu, the scan is executed with your user privileges. It can only access files that you (current user) can.


    If you instead do a full system scan, the scan is executed with system privileges and it can access all files.


    Hope this helps.



    (F-Secure R&D)



    F-Secure R&D, Desktop products

  • Simon
    Simon Posts: 2,667 Superuser
    Also, to scan all files, don't you need to untick the box in Anti Virus that says 'Only scan known file types', or similar? Can't remember the exact wording off hand.
  • Thanks Ville, that IS helpful but disappointing. I tried last night and it appears that current user privileged is also the case if you do a custom scan. Is there any workaround for this? I don't want to scan the whole system, just an attached, slaved Windows drive from another computer.
  • NikK
    NikK Posts: 903 Forum Champion

    I haven't tried with a slaved Windows drive from another computer so I don't know about that, but I have successfully scanned another windows drive as a network mapped drive. The difference with a network mapped drive is that I have to pass credentials to it when I connect to it(as administrator). So maybe it's a permissions problem. Also any encryption on the drive could cause this including windows EFS which is very easy for any user to apply. (folder properties, advanced, encrypt)


    You could try the FSAV command-line utility. Example here including scanning as system account instead of current user: 


  • NikK
    NikK Posts: 903 Forum Champion

    Hi again, I don't know the reason why you connected a windows drive from another computer as a slave, but my advice(if it's possible) is to put it back and then map that drive as a network drive. Then scan that network drive from your own computer. That has always worked for me.

This discussion has been closed.
Pricing & Product Info