TP99 - Safe Search

SimonSimon Posts: 2,618 Superuser

The email:

 

---

 

Hello,

We are releasing a new version of F-Secure Internet Security Technology Preview (ISTP99) today! This release brings out lots of bug fixes for issues reported from previous versions plus a totally new Safe Search browser integration.

With the latest version it is possible for you to set the Safe Search page as one of your home/startup pages, or as a Search Provider, or even add an extra toolbar to your web browser. With these features we want to bring the Safe Search more easily accessible for you and take away the need to always go through the Launchpad. With Safe Search quickly accessible, you will always get your search results rated by our own best of the class reputation engine.

After a clean installation or an upgrade you will be prompted to take Safe Search into use.

If you encounter any issues with the latest version, please report them through https://beta.f-secure.com as soon as possible.

Best Regards,
F-Secure Beta Piloting Team
 
----
 
I don't know if it's me being thick, but I can't see anything different about Safe Search on IE11 (Win 8.1), and wasn't prompted to "take Safe Search into use".  Has anyone else tried it and got different results?

 

Comments

  • VilleVille Posts: 495 F-Secure Employee

    Hi Simon,

     

    There was a bug in the upgrade which caused the prompt to not appear for many people. You should get the prompt after you reboot or log off and log in to the computer.

     

    Ville

     

  • SimonSimon Posts: 2,618 Superuser
    Hi Ville,

    I did reboot a couple of times, and also reinstalled the browsers add-on, but the prompt didn't appear on either my Windows 8.1 or Windows 7 machines. I'll try it again when I next power them on from cold.

    Simon.
  • Any news regarding this?

    Maybe you didn't receive the upgrade at all yet?
  • SimonSimon Posts: 2,618 Superuser
    Yes, upgrades definitely received on both machines. Sorry, but I've not been at home to test today, and won't be till later this evening.

    I did also file a bug report via the beta program, with more details.
  • SimonSimon Posts: 2,618 Superuser

    @Janiashvili wrote:
    Any news regarding this?

    Maybe you didn't receive the upgrade at all yet?

     

    Jan,. any chance of a screenshot., showing what I should be seeing?  I currently have SafeSearch set as my Home page in IE11, but it was before this upgrade.  I am seeing a link under the actual search box to "Add F-Secure Safe Search as your search provider".  Is that all I'm meant to be seeing?


    Simon.

     

    Untitled.png

  • As it seems, you already received that upgrade... I have no idea(and I didn't screenshot at my upgrade), so lets wait for FS folks
  • SimonSimon Posts: 2,618 Superuser
    OK, hopefully I'll hear back from the beta team, and will post any updates here.
  • VilleVille Posts: 495 F-Secure Employee

    Hi Simon,

     

    You should see an F-Secure Acion Center prompt asking you to enable Safe Search. See screenshot. It's only shown if your current default browser is up-to-date Internet Explorer, Chrome or Firefox.

     

    Ville

     

    safesearch.png

  • SimonSimon Posts: 2,618 Superuser
    Hi Ville,

    No, definitely never saw that on either machine, with IE or Firefox, both latest versions.

    It would be useful if anyone else could confirm whether they saw this screen or not.

    Simon.
  • VilleVille Posts: 495 F-Secure Employee

    Hi Simon,

     

    Could you please create a bug report about this through beta.f-secure.com. We are definitely interested to see the logs about why it did not open and your fsdiag would help a lot.

     

    Ville

     

  • SimonSimon Posts: 2,618 Superuser
    Hi Ville,

    I already have, on the day TP99 was released.

    Regards,

    Simon.
  • VilleVille Posts: 495 F-Secure Employee

    Hi Simon,

     

    Unfortunately I can't find any trace of that bug report. Could you please re-submit it if you still have the problem.

     

    Ville

     

  • SimonSimon Posts: 2,618 Superuser

    Hi Ville,

     

    Apologies, but I have just checked, and the bug report was still sitting there as a draft.  I was sure it had been submitted!  I have now submitted it, but with a current FSDIAG, as the one I had originally attached had disappeared from the draft, and unfortunately, I hadn't saved it on my machine.  Hope that is still of some use.

     

    Simon.

This discussion has been closed.