F-Secure incompatibility with Steam gaming platform (cannot play games)


So this has been a very longstanding issue which I have been in contact both with Steam Support and F-Secure and there is still no solution to the problem.


You cannot play a lot of the games on Steam if you have F-Secure installed, you just get an error in Steam when you try to launch a game.


Here is the KB article on Steam Support about the issue:


Game failed to start (Error code 51)




F-Secure uses a feature called DeepGuard which may interfere with Steam. If you are seeing the above error, disable DeepGuard and re-test the issue. If the issue continues, you may need to *temporarily* uninstall F-Secure to determine the cause of the problem.





However there is no solution to the problem. Nothing works, not even turning F-Secure off in its settings.


I have no idea what to do but to put this up here in the forums. Smiley Sad


  • Ville
    Ville Posts: 694 F-Secure Product Expert



    I'm a gamer myself and have a lot of Steam games. I have DeepGuard compatibility mode set on and have not had any problems with Steam. I have the compatibility mode on for other reasons than Steam, but you could try if that helps.





    F-Secure R&D, Desktop products

  • Thomashamka



    I have the same problem which i fixed like this(I use it in finnish): Open the F-secure console -> Settings -> On the left, the open the second one, connections(?) -> And when you open that open also the second one, controlling the applications. -> Then ADD -> Write STEAM and it opens steam folders, then find the Steam.exe (the normal steam icon) and add it and remember to put ALLOW! After that close steam and open it again.


    Works for me.

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Thanks for sharing, Thomashamka!


    @patet , did either of these pieces of advice solve your issue?  If so, please mark the helpful post as the solution Smiley Very Happy


    // Chrissy

  • patet
    patet Posts: 57 Explorer



    You are apparently using an old version of F-Secure with its own firewall. I am using the latest 2014 version which doesnt have it and I cannot do what you are talking about. I added Steam.exe to the only place I can which is real-time scanning as an exception which didnt fix the issue.

  • patet
    patet Posts: 57 Explorer





    This doesnt happen on all games in Steam, it only affects a certain portion of them and it appears to possibly change.


    But this is a very old and recurring issue...


    Now I got it once again when I tried to play the following game:



    The Secret of Monkey Island: Special Edition







    This is starting to get really frustrating since its such an old and known issue and has just been neglected by both parties even though I've been in contact about the issue for a long time already.


    I cant play the games I have paid for...

  • Thomashamka

    Hello, that is a shame Smiley Sad. I suggest you install Windows security essentials as second firewall / virus defender (which is pretty good) and when you play games on steam platform you just close f-secure. Indeed it is a stupid way to go, but atleast you can play. And you still have firewall and virus defender all the time online.


    Hope this helps a bit.




This discussion has been closed.
Pricing & Product Info