3CX phone application cannot fully connect


I am running F-Secure Anti-Virus 12.83 build 104 and I am having trouble with my 3CX voip phone application. It does not fully connect to the server unless I first turn off F-Secure (Turn Off "Shut down all security features") and then it connects fully.  Then I turn F-Secure back on and and it works for a while...


The problem seems to stem from additional applications (or dll's) that 3cx needs to run and to "fully" connect. See this: http://www.3cx.com/blog/voip-howto/anti-virus-blocking-voice-mail-in-3cx-phone-system/ 


However there is no way to add these applications or dll's to the "Application Settings" as per illustration for AVG. What am I missing?



PS. By saying that it does not "fully connect" I mean that it does not communicate with the server and get the "presence information" and so I cannot see who is online or be on a phone queue etc. It kind of hobbles the product. However I can make phone calls.


Thanks in advance!


  • Ben
    Ben Posts: 2,020 F-Secure Product Expert

    Hello, Codeslinger,


    Could you precise the Operating systems involved in your problem?


    Also have you tried excluding the application from Settings>>"Virus and spyware scanning" and not only from Deepguard?


    Thank you.

  • Ben,

    The operating system is Windows 7 64 bit Professional.


    I also attempted to add the program to the exclusion list in Virus and spyware scanning. I added the whole folder but that didn't work either. I tried adding some of the individual files but I assume by adding the folder I should'nt have to add each file, correct?


    BTW, how come there is no way to add applications to the exclude from scanning?


  • AndyY
    AndyY Posts: 27 F-Secure Product Expert

    Dear Codeslinger,


    You cannot exclude applications directly. New applications appear on the exclusion list only if you exclude
    them during scanning.


    With regards to your problem, I would suggest you to open a Support Ticket:


    Once you have open a SRID kindly update me so that I can help to solve your issue.


    Best Regards,


    Andy Yoon

  • Support ID: 00045512

    Is this what you are looking for?



  • Chrissy
    Chrissy Posts: 406 Active Engager

    Hi codeslinger!


    Did you already receive help through your support ticket, or do you still need our assistance in the Community?


    And if you did find a resolution to the issue, could you please post it here so it might help other users in similar situations?



    // Chrissy

  • I am actually waiting on a response from the "high-level" tech support. So far the only work around I have found is to turn off all security features, let the app connect and then turn F-secure back on. I am hoping they find a fix for the issue, I like fsecure but this is a bit of a pain.

  • SeanV
    SeanV Posts: 19 Former F-Secure Employee

    Dear Codeslinger,


    We would like to inform that we have highlighted your case and the engineer who is working on your case will be replying you as soon as possible.

    Please feel free to contact us again should you need further assistance.

    Best Regards,
    Sean Veloo

    Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.

  • Any answers for this yet?

  • Jake
    Jake Posts: 74 Former F-Secure Employee


    Try excluding the port 5000 of 3CX Phone System server from Web Traffic Scanning.

    Correct format is following (http://ip address: port number/*)


  • @tolu82 

    The answer is yes and no. Yes in that a tech from Singapore was able to make it work after 2 or 3 tries. It then worked well (btw there was no good explanation given as to what was wrong). Recently I received a notification that I should update F-Secure which I did. The update promptly broke the system again. So in the end the answer is no.


    I have been too busy to deal with tech support again to get it fixed. It's kind of annoying turning the security features off, reconnecting, and then turning them back on again..


    @Jake How do you add that exception in the F-Secure Antivirus product?



  • I must add that I'm using F-Secure Protection  Service for Business, for workstations.



    @Jake But no the suggested solution did not work for me.

  • @codeslinger


    Got a message from F-Secure support.


    Stopping the service FSGKHS and renaming the following:











    to filename.sys.old


    Starting the service FSGKHS.


    This worked for me!

  • @tolu82  You must have a significantly different version than I do. I do not have the FSGKHS service.


    So what I did was turn off all of the F-secure services and rename the fsni64.sys and reboot.

    Will post back if it works.

  • @codeslinger 


    I'm using F-Secure PSB Workstation Security as I mentioned in an earlier post.


    Got a new message from F-Secure where they said that the renaming of files was just a step to pinpoint the problem.



    When it worked after doing this procedure they told me that the problem is caused by the Network Interface Framework module.


    Still waiting for the next step.

  • Ok, here are my results. I renamed that file "fsni64.sys" and rebooted my computer. 3cx now works just like it should.


    Now I am concerned that F-Secure is operating correctly. Maybe one of the techs could fill us in.

  • Jake
    Jake Posts: 74 Former F-Secure Employee

    That testing confirms, that the problem is caused by Network Interceptor Framework.

    Have you excluded all 3CX server ports from Web Traffic Scanning?

    See pg. 14 of Manual 3CX Phone System for Windows Version 12


  • @Jake That would make sense, however I cannot find the interface/ui to exempt ports from scanning in my version. I can only exempt programs...of which 3cx is listed as a trusted program.

  • Chrissy
    Chrissy Posts: 406 Active Engager

    Hi codeslinger,


    since there hasn't been any activity on this thread for a few weeks, I just wanted to check in and see if you still have any issues to be addressed?




    // Chrissy

  • Hello,

    Addressed, no not really. I am running f-secure with the network filter (??) disabled. I have the above mentioned file renamed and now it works. Kind of seems like it defeats the purpose of an anti-virus software. My subscription runs out in a few days and at that time I am planning on trying a different company to see if things work better. The 3cx application is really the only compaint I have about F-Secure.

    AWCSDT Posts: 2

    Good luck on that, you'll get their auto responses then they just ignore you and hope you go away.  No answer on this and I've been trying for a month.

This discussion has been closed.
Pricing & Product Info