Mac Anti Virus update?

I've started getting a popup to install an update for Mac Anti Virus - could someone confirm that this is a real push? 

Two differences that are in this 'new' installer but not in the installer available from F-Secure's site:

1) The installer window has green banner text under the installation steps

2) The pop up installer license terms have no date

 

I've tried to chat with support, and been disconnected each time after a 10 minute wait

 

Thanks

Best Answers

  • drisisdrisis Posts: 2
    Accepted Answer

    Spoke with tech support. There was a push, and some people are having issues with the installation files. Suggestion I received was to uninstall and reinstall the Fsecure AV application.

    Here's what I was told:

    Caveat lector, I have not tried this yet...

     

    Regards to this issue, the latest version of F-Secure Anti Virus has been pushed. The size of the installer should be about 20MB. We recommend you to use the steps below in order to upgrade/reinstall the F-Secure program.
    
    A) To uninstall the F-Secure Antivirus for Mac
    1.Open the folder where you installed the product. By default, the product  is in the Applications folder.
    2.Open the F-Secure folder.
    3.Double-click the Uninstall F-Secure Anti-Virus for Mac icon. The  uninstallation program opens.
    4.Click Uninstall . You need to enter your administrator password to  uninstall the product.
    5.Enter your administrator user name and password and click OK .
    
    B) To install the F-Secure Antivirus for Mac
    Download link
    http://download.f-secure.com/estore/f-secure_anti-virus_for_mac.dmg
    

     

  • RedLeaderRedLeader Posts: 2
    Accepted Answer

    @drisis wrote:

    Spoke with tech support. There was a push, and some people are having issues with the installation files. Suggestion I received was to uninstall and reinstall the Fsecure AV application.

    Here's what I was told:

    Caveat lector, I have not tried this yet...

     

    Regards to this issue, the latest version of F-Secure Anti Virus has been pushed. The size of the installer should be about 20MB. We recommend you to use the steps below in order to upgrade/reinstall the F-Secure program.
    
    A) To uninstall the F-Secure Antivirus for Mac
    1.Open the folder where you installed the product. By default, the product  is in the Applications folder.
    2.Open the F-Secure folder.
    3.Double-click the Uninstall F-Secure Anti-Virus for Mac icon. The  uninstallation program opens.
    4.Click Uninstall . You need to enter your administrator password to  uninstall the product.
    5.Enter your administrator user name and password and click OK .
    
    B) To install the F-Secure Antivirus for Mac
    Download link
    http://download.f-secure.com/estore/f-secure_anti-virus_for_mac.dmg
    

     


    This worked for me :)

Answers

  • RedLeaderRedLeader Posts: 2

    Same here - F-Secure appears to want to run an update on my Mac but when I do it (after entering my laptop's admin password - d'oh!) it fails with an odd error - something about not being able to find the data?

     

    My details:

    F-Secure Anti-Virus for Mac (B11500.C110)

    OS X 10.7.5 (11G63)

  • Same here.

    Here is the box. It's very persistent, keeps popping up.

    Screen Shot 2013-07-17 at 12.29.02 PM.png

  • aaapeeceeaaapeecee Posts: 1

    I've got the same message yesterday at first ant today also. Installation message was written in Finnish. Anyway installation fails with message: Can not find data for installation. I am waiting for F-Secures comments.

  • Ake72Ake72 Posts: 1

    same problem here, awaiting for  a solution...

     

    We have two macs and there was no problems with the second one.

  • hunt65hunt65 Posts: 1

    I am getting this pop up alle the time here on my Mac , that are saying that i need to update my F-Secure

    But when i try it always go wrong.

    What is this ??

  • AuntyOofAuntyOof Posts: 2

    I am also get this persistent message with the same inability to install telling me it can't find the data to install.  I checked my subscription date and it's not due to expire until October this year. What's going on F-Secure?

  • bracebrace Posts: 1

    Same problem.. The message is appearing every now and then. But no chance to update. No need for the product update yet. 

  • ScottyScotty Posts: 1

    I started getting the same pop-up as of yesterday.  When I do the Exclamation Mark that the data couldn't be found....etc., I immediately thought Virus/Trojan scam!  I ran a scan to make sure I didn't fall victim of an intruder...and everything was clean..now I just hit Remind Later..then it comes back an hour later.  This is suspicious; however, what I find even more troubling is no response from F-Secure.  I will cancel my subscription and remove the program if it persists.

  • AuntyOofAuntyOof Posts: 2

    Worked for me as well!  Smiley Happy

  • Ruben47Ruben47 Posts: 1

    I struggled with the problems for several days. I had installed the F-Secure directy from F-Secure.fi in 2012. My Internet connection provider sells the same program under it's own brand, so I installed it, after which the problems appeared. Finally I found the reason: F-secure was installed in 2012 in the folder "F-secure" in my Mac's Library section. The internet provider's F-secure files were installed in the Mac's Application section. After removing the files from the Library section the problem was solved.

This discussion has been closed.