Browser Plugin Protection for F-Secure 2012 Internet Security

RusliRusli Posts: 999 Adventurer

Hi All,

 

I need help.

 

There seems to be a browser plugin protections for F-Secure Internet Security 2011.

 

is there any browser plugin protection for F-Secure Internet Security 2012???

 

How do I go about it to do the configurations.

 

Does the latest version of browsers supports it???

Comments

  • Hi Rusli,

     

    Below are the list of the supported browsers:

     

    • Internet Explorer 7 & 8 (Windows XP), Internet Explorer 8 & 9 (Windows Vista & Windows 7)
    • Firefox 3.5, 3.6 , 4 – 19

    However, we would suggest you to upgrade to the lastest version of F-Secure Internet Security 2013 where you will have a better protection.

  • RusliRusli Posts: 999 Adventurer

    Thanks.

     

    But I need to know if the F-Secure 2012 Internet Security.

     

    Does it have the features to browser plugin blockage?

This discussion has been closed.