F-Secure unable to got updates from Server

Dear all

Since 3 weeks, I try together with the F-Secure support to solve my problem of not receiving any updates. The history was:

  • I got a new installer for F-Secure Internet Security 2013
  • I installed it and since then I do not get any updates.
  • on several websites I saw, that maybe the uninstallation of version 2012 was not cleaning up all things completely and in parallel I got the uninstaller from support
  • I uninstalled the whole product with the uninstaller and I cleaned-up the windows registry
  • I started the installation again, but the problem is still occurring even when configuring google dns-server

The status of my database entries are all on "waiting for updates". In parallel I observed in the update windows, that the date of last update check is moving very fast and to very bizare dates: I got last update checks in 2006, 2010, 2012, 2014, 2026, 2077, etc.

 

Does somebody of you already had a seemless problem?

Best regards and thany you for support

Matt

Best Answer

  • matt_01matt_01 Posts: 6
    Accepted Answer

    Dear all

     

    Problem fixed! I did the following steps:

     

    1) uninstalled FSIS 2013 from control panel

    2) used the installer from ftp://ftp.f-secure.com/support/tools/uitool/

    3) reboot

    4) manually cleaned up windows registry from all relevant F-Secure entries - this is only for advanced users...

    5) installed FSIS 2013 again but without the real-time network option

    6) finished installation and configuration

    7) updated the virus definitions...

     

    Thanks to all having posted replies to my problem. A combination of lots of your inputs solved my problem!

    Regards

    Matt

Comments

  • RusliRusli Posts: 991

    Hi

     

    Have you try one of these.

     

    Check the readme files first.

     

    ftp://ftp.f-secure.com/support/tools/uitool/

     

    http://community.f-secure.com/t5/Security-for-PC/How-do-I-uninstall-the-product/ta-p/15384

     

    Uninstall and reboot.

     

    There must be something that is conflicting.

  • Hi matt_01,

     

    With regards to your problem, I would suggest you to open a Support Ticket:
    http://www.f-secure.com/en/web/home_global/support/contact

     

    Once you have open a SRID kindly update me so that I can help to solve your issue

     

    Thanks.


    Best Regards,
    Jagadesan

  • Hi Jagadesan

    I opened a ticket 4 weeks ago, but except uninstalling, new installation and changing the dns-server settings I did not got any other help... :-(

    Regards

    Matt

  • Hi matt_01,

     

    Could you provide to me the SRID so that I can take a look at the case?

     

    Thanks.


    Best Regards,
    Jagadesan

  • Jagadesan

     

    Sure you can get it: SR ID:1-529190989, but the exchange was mainly in German, hope you get the content. Summary:

    - I tried to use the DNS-server of google => no success

    - I completely removed Internet Security incl. registry-clean up

    - re-installed F-secure, but still the problem of no updates persists...

     

    Thank you

    Matt

  • Hi matt_01,

     

    With regards to your problem, I have created a new SRID for your reference. I will be analysing the case and update you as soon as possible. The new SRID: 1-533360136.

     

     

    Thanks.


    Best Regards,
    Jagadesan

  • RusliRusli Posts: 991

    Have you activate your subscription key before updating???

  • Yes I did. At least the license expiry date is displayed correctly in the settings.

    Regs

    Matt

  • RusliRusli Posts: 991

    Matt,

     

    During installing the F-Secure Internet Security did you try to disable the F-Secure DNS?

     

    See if it works...

  • No, I didn't. Is this only possible during installation or as well once installed and if yes, where?

    I guessing since longer time, that somewhere on my system I have blocked the access to the update-servers for F-Secure. I checked the Windows Firewall and as well the network settings but I did not find anything...

     

    Regards

    Matt

     

    PS: before version 2013, F-Secure had a own Firewall, now it is using Windows Firewall and maybe the blocking is in there...

  • RusliRusli Posts: 991

    Matt,

     

    The F-Secure DNS option usually starts during the fresh install of F-Secure Internet Security 2013.

     

    You have to try to unselect it. See if it works. (Only during the Fresh install of FSIS 2013)

     

    It might be that using the F-Secure DNS is conflicting your ISP own DNS server.

     

    But can you surf the web??? When having the F-Secure DNS enabled???

     

    What about your Network Settings. Did you have to key in any Static DNS ip address on your Windows Network Settings???

     

    If you do, try disable the F-Secure DNS during the fresh install of F-Secure Internet Security 2013.

     

    What OS are you using??? Windows XP, Vista or Windows 7??? Can you do any other software updates beside FSIS 2013???

     

    Did your Router block the F-Secure DNS ip address??

  • RusliRusli Posts: 991

    Once you activate your subscription key it will auto update the virus definition files.

     

    The next FSIS 2013 virus definition files update will be done hourly.

     

    So if you try to manually updates, you might have the latest version of virus definition files.

     

    It usually states that you have the latest updates.

     

    You need to find out and isolate the problem one by one.

     

    Which I said previously.

     

    If any the methods that I shown you did not work. You need to get help from F-Secure tech support by creating a new ticket.

     

    Via this site:-

     

    http://www.f-secure.com/en/web/home_global/support/contact/request

     

     

  • RusliRusli Posts: 991

    Hi

     

    Job well done!

     

    That's is what I'm try to say...

     

    Can I get Kudos for this?

  • etomcatetomcat Posts: 1,312

    Hello,

     

    > 5) installed FSIS 2013 again but without the real-time network option

    > 6) finished installation and configuration

    > 7) updated the virus definitions...

     

    If you never turn the "F-Secure real-time protection network" option ON, then the computer is lesser protected, only about 2/3rd degree, compared to a "real-time network" enabled computer.

     

    Modern security suites depend a lot on Cloud-based protections, because having everything in locally downloaded databases would prove too heavy on the system resources. Therefore, sending queries to a Cloud server farm via the public Internet is necessary to maintain a high degree of protection.

     

    Bye, Tamas Feher from Hungary.

This discussion has been closed.