FSIS 2012 Update fails with remove "Conflicting security product" and corrupt filesystem


Today I did accept the update request of F-Secure which resulted in an un-protected computer, many files lost, failing applications and the sorts... needless to say I regret the update request.


What Happened so far?


The update downloaded automatically and the installation started but fails during setup. It says "the application could not be installed because some product could not be removed automatically. Remove the following products manually and try again. : Conflicting security product"


It does not tell me WHAT conflicting security product!


I did not have a similar issue when I installed this software at the beginning of this year, prior this update.


Assuming it was in conflict with itself, I rebooted the PC, but at startup, windows detected a huge amount of file system errors, of which some were definitely fsecure related files. Many files were removed during the automatic chkdsk during startup. I do fear multiple applications are affected by this. Forinstance Outlook does not run anymore.


Now I have two system tray Fsecure app icons. One security panel which shows subscription is valid and internet security as not installed, while the other has a blinking red cross which says "Expired" after each product.


The Programs and features controlpanel app strangely does only show F-secure Security Panel , no other F-Secure products are there to de-install.


I am running Windows Vista.


Any help is appreciated.



  • garlangreeny
    garlangreeny Posts: 15 Observer

    This is what I usually encounter whenever I do an upgrade with F-Secure which it came to a point that it would be best to read more about the update before updating. Sometimes, you get more problems than fix once you do. image

  • Robo4o
    Robo4o Posts: 5

    The un-installer (from the link from Gary) and then re-installing the original product was finally the solution.


    Apparently, the updater complaining about some unknown conflicting security product was one of its own that was cured by un-installing F-secure.


    Among other things I tried to install the F-Secure 2012 from the link Gary provided. It did install, but of the two registration keys I have, none worked.


    Thanks Gary.

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi Robo4o,


    What is the error message received when you try to validate? I would suggest you to open a Support Ticket to check your subscription keys:




    Best Regards,

  • Robo4o
    Robo4o Posts: 5



    As far as I remember, there was no error message, only the continue button stayed gray after it tried to validate the key.


    It might be that I have a key for some OEM version as supplied by/for my ISP. There is no about box that tells the version of the product that I have installed, so, I can't tell if this is really FIS 2012 I am running.


    Anyway, I'm not interrested in having exactly FIS 2012 running, I'm only interrested in having a good and reliable virus scanner.


    I'll not open a support ticket for this.



  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi Rob,


    If the product license key is from your ISP, you might be using a customized version of F-Secure software. Kindly contact your ISP in order to obtain the correct installer to reinstall the software.


    Best regards,


This discussion has been closed.
Pricing & Product Info