Firefox Flash plugincontainer CPU hog with F-Secure DeepGuard


With F-Secure DeepGuard enabled, it is impossible to play Flash (and other stuff) in Firefox on Windows 7 32 bits. CPU on one of the cores goes to maximum, caused by the plugincontainer process and Firefox becomes unresponsive. With DeepGuard disabled, everything works as it should and plugincontainer is behaving nicely: no CPU, only Flash is using resources.


Please look into this issue as I'm now forced to disable DeepGuard to have a proper experience. Thanks.



  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee



    which version of Firefox are you using?

    Which F-Secure product and version are you using? DeepGuard is a feature, unfortunately we cannot get an idea what product you are using.


    Is the "use advanced process monitoring" feature for Deepguard activated? Have you tried only disabling advanced process monitoring but overall leaving DeepGuard activated?


    Thanks for your input.

  • rutger13

    Thank you for your response.


    Firefox 14.0.1


    F-Secure through XS4ALL. I'm sorry I can't find any about box in your product. So I too have no idea which product I'm using. Your product's UI seems to be lacking this information.


    I did some experimenting and disabling advanced process monitoring seems to be sufficient, thank you. I suggest you publish this on the Mozilla site since the general consensus there is that F-Secure with Firefox is a troublesome combination.


  • garlangreeny
    garlangreeny Posts: 15 Observer

    I am currently on Firefox version 13 and am about to update it. I just hope I won't encounter this one. image

  • rutger13
    This problem already existed in 13. I upgraded to 14 hoping that it would be fixed. But it appears to be caused by F-Secure settings, not Firefox.
  • MichielT

    I had precisely this problem. I can confirm that the problem is solved bvy leaving DeepGuard enabled and only disabling the suboption "use advanced process monitoring.


    Firefox 14.0.1

    F-Secure  Internet Security for Windows 9.16 build 131

    Windows 7 Enterprise SP1 x64


    The process that starts maxing out on cpu is plugin-container.exe. 

    Should be easy enough problem to recreate, and a bit of Googling turns up plenty of other people having the same problem.


  • Tixxr
    Tixxr Posts: 1

    Exactly same issue right now with F-Secure Internet Security 2011

This discussion has been closed.
Pricing & Product Info