F-Secure IS 2012 Updating is stuck and a whole bunch of other problems


How to make a long story short...

I have 1-year-old Asus G74S gaming laptop with Windows 7 home premium 64-bit and it comes with preinstalled Oberon games. I tried uninstalling these games, since I never play them and that made F-Secure Internet Security 2011 think that it had expired, though it has 1 year time still left. I have license for 3 computers and it's currently on my and my bf's computer. I heard from my brother who has the same computer (but older version) that he had the same problem, that when he tried to uninstall those games it disables F-Secure and even though it's on my computer, I couldn't access it at all and it flashed complaining it had expired.

After restoring my system from the last recovery point where it worked, F-Secure worked fine and I updated it into 2012. Atm, I didn't know it was the Oberon games screwing up my laptop, so I tried uninstalling them which gave me the same problem with F-SEcure thinking it had expired.

This time going back to the recovery point where my OS still worked didn't work, F-Secure kept telling me it had expired. My father installed 2012 and after that F-Secure claims I have used 3/3 of my product keys, since it didn't delete 2011 and installed 2012 so I had both of them on laptop. My father made it work out by uninstalling Malware Bytes (which I used to scan my pc when F-Secure stopped working, but it wasn't a virus), so we thought now I have a working F-SEcure 2012 on my laptop. Sadly no. Smiley Sad


So, now my firewall on my F-Secure Internet Security 2012 kind of works, but virus database has been "updating" for the last 3 hours now and it seems to be completely stuck there. I do not have other firewalls blocking it, but it still isn't going anywhere and the Online Scan couldn't find viruses and neither did we find them earlier. The Health Check complained about me not having any kind of virus protection at all. Only firewall is working and the rest pretend to be updating, but when I check manually for updates, it says that my product is updated - but it isn't. For the last 3 hours I've been searching through help and forums on this site, but nothing seems to work.


On top of that, now a game I play, League of Legends, won't start at all and I blame F-Secure for it. It shows it's been allowed and when I press Play on the launcher, it starts, but them the program "shuts down", meaning it goes hiding somewhere, since if I try it again, it says the application is already in use. I didn't have these problems yesterday when F-Secure 2011 still worked, so I don't know if the problem is connected to the 2012 version or to the anti-virus not updating itself. Previously the game has never been blocked by anything and it isn't blocked on my bf's and brother's computers either.


This problem took me whole day to "solve" and suddenly it's not solved at all. I wish someone could help me so that my F-Secure Internet Security 2012 would work and update itself and so that I could play again. I don't dare to reinstall again since it says I have used 3/3 of my product keys, although I've only used 2/3, so maybe it will claim I don't have product keys left anymore. It did use an extra key previously, so I'm just being cautious


I'd appreciate if someone helped me ASAP - other than playing games, I need to get back to completing my summer studies and I need a working computer for that.


  • celavey
    celavey Posts: 34 Observer

    Is it possible to cancel the update? I usually get this problem if I have a lot of application running in my system. So I kinda removing almost everything one by one which actually works. image

  • Halipupu
    Halipupu Posts: 3

    No, it's not possile to cancel the update. When I check what kind of protection I have it says anti-virus is updating, but I can't see the progress anywhere. Also whenever I check out updates manually it says I have updated my F-Secure.


    I have fsdiag-file about the problems I had before (with it saying that it has expired) in case it helps to solve this problem. I also found a file recommended by F-Secure that resets all updates and then it loads them again. I'm going to try that and if that doesn't work, I really don't know what to do. I'd be happy to get more replies here.

  • Halipupu
    Halipupu Posts: 3

    Thank you for answering. I don't have 2011 and 2012 both together anymore, we uninstalled 2011 and installed just 2012. F-Secure is still saying that it's updating itself instead of just saying my protection is ok, but when I looked at the anti virus database it had all the necessary (and newest) updates installed, just the program bugs and thinks that it's still updating when it isn't. It's the same even after update reset.

    I think I'm gonna let it be like that since it DOES have the updates even though it doesn't understand that those are finished and installed. If it gives me problems other than that, then I shall uninstall it. For now, I'm going to let it be.


    I also made the game work, it wasn't about F-Secure after all. After restoring my system so many times the files were just fragmented/corrupted, repair installation solved that. Now I just know better than trying to uninstall the Oberon games, but I think you F-Secure people should look into the issue; why it messes up F-Secure to think it's expired when it's not. Obviously Oberon and/or Asus haven't done anything to fix that problem. For now, I just let those games be and not try to delete them.


    Thanks again. :)

This discussion has been closed.
Pricing & Product Info