Freedome replacement does not succeed

Options
Lauri_Kentta
Lauri_Kentta Posts: 2 New Member

Hello, I have F-Secure Total (0 licences left) and Freedome. I've tried to follow the instructions given how to activate new app, but I'm not succeeding in this. Every time I get into My F-Secure nothing happens and I can't perform the activity of replacing the Freedome. I've tried this several times and it basically ends at My F-Secure app.

Please help me out from here !

Tagged:

Answers

  • PawełP
    PawełP Posts: 228 Moderator
    Options

    Hello @Lauri_Kentta

    Welcome warmly to our forum and thank you for your post.
    First of all, I would like to ask if you have a license for F-Secure Total and separately for F-Secure FREEDOME? If so, please let me know in a private message on the forum on which email addresses you have My F-Secure accounts. I will be able to check it in our system.


    Another issue is that until recently, users who had a license for Total could separately install FREEDOME and ID Protection under that license. Currently, this is no longer possible. This means that if you have a Total license for 3 devices, you can install the program according to the license on 3 different devices and use the VPN and Password Vault functions, but you will not be able to additionally install the standalone FREEDOME and ID Protection program on other devices under this license.
    I hope these explanations will be helpful.

    Best regards.

    Pawel

    Making every digital moment secure, for everyone


  • Lauri_Kentta
    Lauri_Kentta Posts: 2 New Member
    edited May 21
    Options

    Hi Pawel,

    it seems I have bought Freedome as a separate product @iki.fi

    2017 I accidentally bought Freedome on my other account @gmail.com, but used a fair amount of time to uninstall and reinstall with my other account @iki.fi

    I'd be glad if you guided what I should do next?

    -uninstall freedome?

    -install F-Secure VPN somehow from Total?

    thanks

    Edit: PII removed

Product & Pricing Info