Firefox with F-Secure Browsing Protection AddOn: AddOn crashes with certain site(s)

Options

Hello

I Use the Firefox latest release with the F-Secure Browsing Protection AddOn in v.5.5.11 on Windows 10 Pro (64-bit) (with latest updates).

The site "corsair . com" crashes the AddOn in Firefox and it's then no more functional with Google Search.

Please fix it.

Thanks in advance and greetings

Alpengreis

PS: Sorry for the complicated link (was not allowed to post links yet).

Accepted Answer

  • Firmy
    Firmy Posts: 1,738 Community Manager
    Answer ✓
    Options

    Hello @Alpengreis1

    Welcome to the F-Secure Community. Thank you for your post.

    I've been able to replicate the issue on my end, and it appears that the problem is isolated to the website https://www.corsair.com/us/en . Specifically, the green tick indicating that the website as safe is missing after visiting the Corsair website.

    Upon testing other sites, everything seems to be functioning correctly. Therefore, it's important to note that the issue does not stem from our browsing protection; rather, it seems to be specific to the Corsair website.

    However, I've observed that if the green tick is missing after visiting the Corsair website, temporarily turning off the browsing protection extension and then turning it back on seems to resolve the issue.

    I would recommend trying the same approach on your end.

    If you have any further questions or concerns, please feel free to reach out.

    Thank you for your attention to this matter.

Answers

  • Alpengreis1
    Alpengreis1 Posts: 3 Observer
    Options

    @Firmy

    Hello and thank you for your response and testing.

    Yes, I knew that workaround already (works here too). But it needs to be fixed anyway.

    Greetings and good weekend.

  • Alpengreis1
    Alpengreis1 Posts: 3 Observer
    edited May 6
    Options

    Ok, here the debug logs …

    Edit: PII removed

Pricing & Product Info