Is it just me or is the VPN insanely slow ?

Options
Youkai
Youkai Posts: 5 Observer

I am trying to watch crunchyroll from Japan trough a VPN in Europe but no matter which Server I try I only get about 1mbit at best when doing a speed test while being connected to any of the European servers ....

The Asian ones are like 20mbit which would be sufficient but don't work with crunchyroll.

its the only thing I need the VPN for but like this I can not even watch 360p -.-V

Also doesn't matter if I use the freedom vpn or the total security and vpn :/

Accepted Answer

  • Firmy
    Firmy Posts: 1,740 Community Manager
    Answer ✓
    Options

    Hello,

    We have successfully identified the root cause of the issue. It appears that the recent updates to all Chromium-based browsers, including Edge, Chrome, and Brave, to version 124, have introduced a new feature called "TLS 1.3 hybridized Kyber support." This feature seems to be causing difficulties with our VPN service. We are currently conducting further investigation into this matter.

    In the interim, as a workaround, we recommend disabling this feature in your browser settings. You can do this by accessing chrome://flags or edge://flags. We appreciate your understanding and patience as we work to resolve this issue.

Answers

  • Youkai
    Youkai Posts: 5 Observer
    Options

    Just tried is using Turbo VPN (free) and got 20mbit ....

    I'd assume that a paid service would get me at least the same results if not even better :/

  • marmab
    marmab Posts: 35 Moderator
    Options

    Hello @Youkai

    Welcome to the F-Secure Community. We thank you for your post. We are currently working on fixing this issue. Regardless of the subscription being free or paid the connection speeds should be as you are currently experiencing.

    When attempting to browse the internet, please could you try using the Firefox browser and let us know if there is any eleviation of the current issue.

    Please bear with us as we are currently working on a fix for this issue.

  • Cotr
    Cotr Posts: 1 Observer
    Options

    First day with the new app. Painfully slow at least here in Finland. Furthermore I had to uninstall the old freedome manually or else neither of them worked.

  • Youkai
    Youkai Posts: 5 Observer
    Options

    I use Chrome and Firefox on my laptop and chrome on my phone but its all the same ...

    If there is an issue on your side it wouldn't make sense it it was only with a specific browser oO

    The VPN tunnel just seems super slow, guess either your servers have some trouble or your ISP doesn't give you enough upload speed for all your users...

  • Firmy
    Firmy Posts: 1,740 Community Manager
    edited April 25
    Options

    Hello @Youkai @Cotr

    As mentioned by @marmab earlier, our team is actively investigating the issue. In the meantime, we recommend using Firefox as an alternative browser.

    To assist us further in diagnosing the issue, we kindly ask you to run some diagnostic commands while the VPN is connected and the issue is ongoing. Here are the commands to run:

    curl -v -6 https://www.f-secure.com/fi -o NUL
    
    curl -v -4 https://www.f-secure.com/fi -o NUL
    
    nslookup yle.fi 2001:4860:4860::8888
    
    nslookup google.se 8.8.8.8
    
    tracert -4 google.com
    
    tracert -6 google.com
    

    And report what those commands print.

    Additionally, you can try disabling IPv6 temporarily to gather more information. Here's how to do it:

    1. Open the admin command prompt and enter:
    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /v DisabledComponents /t reg_dword /d 255 /f
    

    2. Reboot your computer.

    3. Check if the browsing issue persists on Chrome or Edge. Please note that this may slow down OpenVPN connection establishment, but it should not affect IKEv2 connections. We'd appreciate your feedback on whether this helps resolve the issue or not.

    If you need to re-enable IPv6, use the following command and reboot your computer:

    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /v DisabledComponents /t reg_dword /d 0 /f
    

    Thank you for your cooperation and patience as we work to resolve this issue. We look forward to receiving your feedback. Have a great day.

  • JOnes
    JOnes Posts: 486 Rock Star
    Options

    In situations like this, it would be nice if the investigation and its status could be monitored and checked
    a) following the entire announcement queue (new option in
    community)
    b) https://status.f-secure.com/ by following the status window

  • Youkai
    Youkai Posts: 5 Observer
    Options

    No idea what you did ... for a second I was worried that I am an idiot user talking crap BUT actually on my Laptop there is only Firefox installed and no chrome at all, on the phone I used chrome yes.

    But before on m laptop even using firefox the speed was ridiculous now I get 45mbit down and 15mbit up which is more then enough to watch my series.

    Kinda doubt that it had anything to do with chrome as it was definitely 100% the same in Firefox before.

    Anyways it seems to work well again so whatever :/

  • siramic
    siramic Posts: 123 Adventurer
    Options

    @Firmy

    Done, disabled the Kyber support flags option in Chrome and will give it a go over the weekend.

  • Sim0n
    Sim0n Posts: 5 Explorer
    Options

    Done and happy to report the vpn is now working as expected for now.

  • JOnes
    JOnes Posts: 486 Rock Star
    Options

    Still waiting for the stable version(without any browser setting changes) for F-Secure Total &Vpn

    • Windows 11, Windows 10 version 21H2 or later, Windows 8.1
    • macOS 12 (Monterey) or later
    • iOS 16 or later
    • Android 10 or later

  • Mike-North
    Mike-North Posts: 11 Enthusiast
    edited May 6
    Options

    This fixed my connection problems on win10 + brave and chrome.

    EDIT: What is funny is that the VPN has been slow and dropping off for quite some time now. But this chromium feature was rolled out on 16th of April -24. ???

  • Sim0n
    Sim0n Posts: 5 Explorer
    Options

    So any news on the fix and not the workaround?

  • Rockyrider
    Rockyrider Posts: 15 Enthusiast
    Options

    This is still ongoing, The VPN is painfully slow and most times will not connect to the web page ?.

  • LandoMando
    LandoMando Posts: 1 Observer
    Options

    @Rockyrider did you try disabling "TLS 1.3 hybridized Kyber support" as mentioned in the Accepted Answer above?

  • Rockyrider
    Rockyrider Posts: 15 Enthusiast
    Options

    I did thanks and yes, it is better.

  • arnes
    arnes Posts: 1 New Member
    Options

    VPN is still very slow. Occasionally it's better, but most of the time I have to switch it off.

    Speednet results:

    • VPN off: 766/60 Mbps
    • VPN on: 345/56 Mbps

    With VPN download is 50% slower. Not acceptable. Chrome and TLS 1.3 hybridized Kyber support disabled. If it was only speed I could live with this, but connecting to sites takes too long and get http errors.

  • Youkai
    Youkai Posts: 5 Observer
    Options

    Wow how do you even get that speed.... using firefox I get ~1mbit if I am lucky ... also ping of 400 using firefox.

    Might be because of my Location in Japan connecting to Europe ?

    also admittedly even without the vpn I only get like 10-20mbit in my flat :/

    But I also have to turn it off to watch videos as well if I want more than 360p, luckily it does work on crunchyroll on the website (doesn't work with the app as the stream stops when disconnecting the vpn)

  • ClaudeD
    ClaudeD Posts: 29 Contributor
    edited May 28
    Options

    Hello,

    It's been over a month since F-Secure VPN had issues due to TLS 1.3 hybridized Kyber support with Chrome, Edge,…
    This problem is still not resolved.
    In addition, no news is given regarding the progress of the resolution of this problem.
    This is very disappointing.

Product & Pricing Info