F-Secure: Airdrop not working

Options
salamandra
salamandra Posts: 1 New Member

Hello

Again, AirDrop is not working between my iPhone and my Mac. The last time, I was able to get it working, following the suggestion: turn off vpn and trust the network.

Now, even this isn't working anymore. I noticed, that, last time, I was able to trust the 'Bluetooth' Network. But now, I can't add this to the trusted network anymore.

Airdrop not working is really annoying and it would be great, when you manage to solve this issue!

Regards

Barbara von Euw

Accepted Answer

  • OSX_rulez
    OSX_rulez Posts: 27 Enthusiast
    edited February 8 Answer ✓
    Options


    @Firmy

    Hello, apparently using IKEv1 instead of IKEv2 allows to reach the other devices in the trusted LAN. So AirDrop, wi-fi printers, local app (such as AVM Fon) works only if the protocol is IKEv1.

    Why is this happening? AFAIK, IKEv2 is more secure, has less overhead, and should be better for mobile devices! So I think your implementation of the IKEv2 is buggy and does a wrong tunnel even when a trusted network is added.

    Anyway, the Freedome service is still not working properly, after a few days when it seemed more stable, now the same problems a lot of people had reported are still there. The app is disconnecting, it's slow, doesn't load the content etc.

Answers

  • OSX_rulez
    OSX_rulez Posts: 27 Enthusiast
    Options

    I confirm AirDrop doesn't work with Freedome VPN anymore :-(

    Also other services in the trusted LAN are blocked, it's like the option is not fully operational.

  • K_P
    K_P Posts: 53 Enthusiast
    Options

    Same here. Must disable VPN in order to get airdrop work.

    Such a shame that F-Secure has very often issues with Mac products. Their Windows products work ok, and it would be nice to be able to use same security software in all our household devices.

  • VOK
    VOK Posts: 1 Observer
    Options

    The very same problem here. Switching VPN off helps me though. But why pay for something you can't use – I really need to use AirDrop very often in my work.

  • Firmy
    Firmy Posts: 1,740 Community Manager
    Options

    Hello @salamandra @OSX_rulez @K_P @VOK

    Thank you for bringing your concerns to our attention and for providing details on the issue you are experiencing.

    To assist you more effectively, could you kindly furnish us with additional information? Specifically:

    1. Is the reported issue occurring solely on iOS devices, or does it extend to Mac devices as well?
    2. Could you specify the operating system versions on the affected devices?
    3. Is the issue exclusive to the F-Secure Freedome VPN standalone app, or does it also affect the Privacy VPN within the F-Secure Total application?

    Additionally, have you attempted to address the issue by adding the network as trusted and enabling the automatic kill switch? If so, and these measures have not resolved the problem, we appreciate your diligence in troubleshooting.

    Now, even this isn't working anymore. I noticed, that, last time, I was able to trust the 'Bluetooth' Network. But now, I can't add this to the trusted network anymore.

    Regarding the mentioned, please note that this option is not available on iOS devices when using the F-Secure Freedome VPN; it is exclusively accessible on the Mac platform. However, if you are using the F-Secure Total app, this feature is available on both iOS and Mac platforms.

    We recommend trying the aforementioned steps with the F-Secure Total app and checking if the issue persists. Your feedback on the outcome will aid us in further assisting you.

    Thank you for your cooperation, and please feel free to reach out should you have any further questions or concerns.

  • OSX_rulez
    OSX_rulez Posts: 27 Enthusiast
    Options

    @Firmy Hello, I only have the Freedome app on the iPhone and I don't want to install Total on the Mac.

    iOS: whatever 17.x has this problem

    Freedome: 3.5.0.9074

    All the options are already enabled, as I already wrote to you in a direct message.

    The "trusted network" just don't work.

  • Firmy
    Firmy Posts: 1,740 Community Manager
    Options

    Hello @OSX_rulez

    Thank you for your reply.

    Could you please confirm whether you are currently using IKEv1 or IKEv2? The issue you're experiencing might be related to IKEv2. I recommend switching the protocol to IKEv1 and attempting the connection again.

    Please inform us of the results.

    Thank you, and have a great day.

  • K_P
    K_P Posts: 53 Enthusiast
    Options
    1. Is the reported issue occurring solely on iOS devices, or does it extend to Mac devices as well? --> Extends to Mac
    2. Could you specify the operating system versions on the affected devices? --> macOS 14.3
    3. Is the issue exclusive to the F-Secure Freedome VPN standalone app, or does it also affect the Privacy VPN within the F-Secure Total application? --> Applies atleat to Freedome standalone (had to remove Total due to significant performance problem and dysfunctional protection).

    Adding local WLAN to trusted networks seems to solve the issue on with atleast with the stand-alone Freedome.

  • ANM
    ANM Posts: 2 Observer
    Options

    I have similar problem and have to switch VPN off to AirDrop files. Adding the local WLAN as trusted does not help either. This problem developed after latest iOS 17.3 update and respective Total update. I would like o have this sorted out.