F-Secure Total wont work on Windows 11 23H2

AHT
AHT Posts: 2 New Member

Hi. I cant get F-secure total working on windows 11 23H2. I have installed it several times and it installs every time and the icon appears in the taskbar and as an app-shortcut on the desktop, but i can not open it? When I duobleclick the icon nothing happens and when logging in to f-secure account the device is not shown as an device. I have tried to add it several times. I had F-secure Internet security but was updated to TOTAL and now its not working.

Accepted Answer

  • CarolinaC
    CarolinaC Posts: 59 Moderator
    Answer ✓

    Hello @AHT ,

    thank you for contacting us!

    Do you get an error message when trying to install F-Secure on your device?  I would also recommend you to use the Uninstallation Tool which will totally remove all previous versions of F-Secure, so that you can try the re-installation again from scratch. The Uninstallation tool for Windows can be downloaded from this website: https://www.f-secure.com/en/support/tools

    Please also check and delete any F-Secure folders/files under Disc C -> Program Files.

    After deleting F-Secure please follow these steps to reinstall it on your PC.

    1. Log into your My F-Secure account: https://my.f-secure.com/login​​​
    2. Select the device name that you wish to reinstall and click Release License.
    3. A page will appear to confirm the action. Click on Release License. The license is now removed. 
    4. Click + Add device.
    5. Choose My device
    6. Select the device type (the system recognizes your device type by default) and click on Download for Windows.
    7. Once the download is completed, run the F-Secure Safe Network installer.
    8. When the installer launches, click Accept and Install

    In hope this will help to solve this issue. In case of further question, I am looking forward to hearing from you. :)

    Best regards!

    Firmy

Answers

  • AHT
    AHT Posts: 2 New Member

    Hi Caroline.

    I never get any error message during installation.

    I have tried using the uninstall tool and removing any trace of F-secure in C:\.

    I logged into my account and tried to reinstall the software, and it installs wthout any errors and I can see the "f-secure" logo appear on the desktop and in the taskbar. but when trying to open the program nothing happens.

    I never see the device appear in my F-secure account? I have 3 licenses and I can se the other 2 but this computer never appears and it always says remianing licenses 1/3.

    I get a email everytime I log in saying I have logged in from a Windows 10 Chrome 120 unit, but the computer is running Windows 11 and Edge as a browser.

    (Tried running F-SEcure Online Scanner but get a "Pending restart request" everytime, even after restart.)

    Best Regards.

  • CarolinaC
    CarolinaC Posts: 59 Moderator
    edited December 2023

    Hello @AHT ,

    The wrong log in information is an expected behavior in Windows 11. It is detected as 10 by design as the Kernel version in both Windows 10, and Windows 11 is NT 10.0. This is done to maintain application compatibility.

    Regarding the ongoing issue with installing F-Secure I would like to ask you to create a diagnostic file that will collect all the errors when trying to install the program. The file will be redirected to our specialists for checking.

    Since the diagnostic file contains important information, please do not post it here under the post, but send it in reply to my private message.

    Follow the steps below to generate a FSDIAG report.

    1. Download the standalone fsdiag support tool from this website: https://www.f-secure.com/de/support/tools
    2. Double-click and run the fsdiag_standalone.exe file
    3. Click Run diagnostics. The tool starts to gather diagnostic information
    4. Once completed, it generates a file called fsdiag.7z on your desktop
    5. Attach the file to your reply to F-Secure support. 

    I am looking forward to hearing from you!

    Firmy