After 19.2 - Firefox Browser extension needs to set up again and again

laszlo3
laszlo3 Posts: 14 Explorer
edited November 2023 in F-Secure Internet Security

Hi,

F-Secure recently updated to version 19.2. I have a Windows 10 computer with Firefox installed, Firefox has the extension installed already. But after 19.2, F-Secure constantly asks for extension install. So I'm using firefox, then the attached popup appears, and it is driving me crazy.

Tried:

  • Reinstalling the extension - same
  • Ticking don't ask me again - same

This is a new problem, I neved had this with earlier versions. 19.1 and lower was okay, never asked for an extension install, when it was installed. On Microsoft Edge is working fine with don't ask me again, but I don't want to use Microsoft Edge.

Please at least fix "don't ask me again". Looks like F-Secure is not remembering it, or I don't know what the problem is, but I don't bought this software to nag me all the time.


Accepted Answer

  • laszlo3
    laszlo3 Posts: 14 Explorer
    Answer ✓

    Looks like I found the problem. There was a second firefox profile on the PC, what doesn't had the f-secure extension installed. So F-secure was kinda right, but the "don't ask me again" checkbox is still not working.

Answers

  • PawełP
    PawełP Posts: 149 Moderator

    Hi @laszlo3

    Thank you for your post.

    This is an unusual problem so we will need to determine some details.

    Please check first that Windows and Firefox are updated to the latest version.

    If so, please uninstall the extension in Firefox and restart your computer.

    Now install the extension from within our program, i.e. F-Secure > Settings > Browsing Protection > Firefox extension

    Let us know how the situation looks.

    Have a nice day

    Pawel

    Making every digital moment secure, for everyone


    Firmy
  • laszlo3
    laszlo3 Posts: 14 Explorer

    Everything updated to the latest version. I did extension reinstall, and same thing happened.

  • Ukko
    Ukko Posts: 3,603 Superuser

    Hello,

    Looks like I found the problem. There was a second firefox profile on the PC, what doesn't had the f-secure extension installed. So F-secure was kinda right, but the "don't ask me again" checkbox is still not working.

    There was a discussion where explained that all instances or profiles should be with the same state. So, all with 'extension installed' or all with missed extension.

    For example,

    with the quote from first topic: """The suggestion resets itself when it detects that it's installed and then starts from beginning if it becomes uninstalled. This basically can happen by switching profiles, so it looks like "Don't ask again" has no effect."""

    Can you clarify your experience? 'Don't ask me again' checkbox is still not working while both profiles with working extension? Or you decided to leave second one without extension and tried to use that button?

    Thanks!

  • laszlo3
    laszlo3 Posts: 14 Explorer

    I installed the F-Secure extension for all the profiles. After that F-Secure didn't ask about that at all. I understand that logic, and it is fine, but what is not fine is nagging after checking the "Don't ask me again" box.

  • Ukko
    Ukko Posts: 3,603 Superuser

    I installed the F-Secure extension for all the profiles. After that F-Secure didn't ask about that at all. I understand that logic, and it is fine, but what is not fine is nagging after checking the "Don't ask me again" box.

    yes, true. But it is part of mentioned "current" design's trouble.

    however, if F-Secure extension for all the profiles is disabled (not installed). And then you tried to use "Don't ask me again" checkbox - and - then it is not working - that's not fine at all (because then it will be unknown bug or, at least, not confirmed one yet).

    Thanks!

Pricing & Product Info