F-Secure TOTAL - Problem with link Internet

Bernard_1958
Bernard_1958 Posts: 3 New Member
edited November 2023 in F-Secure Total

Good evening,

Some features do not work. I have already had email exchanges with a colleague in French. However, the problem was not resolved and I was told to wait.

 

I am coming back to you because I may have identified part of the cause of the problems I am encountering with the F-Secure TOTAL application.

Indeed, as already explained in our previous email exchanges, out of the six TOTAL protections, two returned an error message. I am attaching two screenshots that I have already sent previously as well as my invoice so that you have my customer data.

 

Today, following an internet problem for a while (I had a speed of 70 to 100), a technician came to check my connection. With his PC, the Speed test showed a speed between 500 and 600 like I had before. He tells me that the problem certainly comes from an application installed on my iMac and my other devices.

 

This evening I tested my speed which was still 100. I uninstalled F-Secure TOTAL and the speed went back to 500. I did the same test on my other devices and I got the same result speed difference with or without F-Secure TOTAL.

 

On the screenshots that I send you, we can read that the error message mentions that there is no connection.

 

Could you check this and try to resolve the problem with the application?

 

Can I ask you to do this as quickly as possible because I am without protection, on my devices and especially the alarm in my house. I thought I was in a black area but now I think it's due to the app.

 

Thank you in advance for your help and diligence.

 

Sincerely,

 

Bxxx


Edit: PII removed

Accepted Answer

  • Bernard_1958
    Bernard_1958 Posts: 3 New Member
    Answer ✓

    Good morning,

    When I disconnect the VPN, the speed is normal at 500 Mbps. When I change the VPN protocol, on Open VPN (TCP), the speed drops to 160 Mbps and on IKEv2, it drops to 240 Mbps.

    Regarding the extensions, the only one I have seen concerns password management and I also deleted it.


    In addition, the protections "person monitoring" and "people and devices" still does not work and gives an error message.


    I remain at your disposal to investigate the causes of these problems.


    Thank you very much.


    Bernard

Answers

  • CarolinaC
    CarolinaC Posts: 76 Moderator

    Hello @Bernard_1958 ,

    thank you for contacting us on the F-Secure Community Channel.

    We are sorry that you are experiencing this problem. Could you please give us more information about your MacOS operating system? Is it the latest version available for your Mac?

    Do you also use a VPN connection? It is quite possible that F-Secure VPN is affecting your internet speed. If you are using VPN, could you please tell me which location you are connected to?

    Here you can find more information on how to improve the internet speed on your device when using Freedome VPN. 

    https://help.f-secure.com/product.html?home/freedome-mac/latest/en/id_81927-latest-en

    Have you tried reinstalling the program using our uninstallation tool? This tool helps to remove the errors of the F-Secure program so if you have not used the tool yet, I would like to ask you to do so. The tool can be downloaded for MacOS from this website:  https://www.f-secure.com/fr/support/tools.

    After the uninstallation please proceed with the reinstallation of F-Secure TOTAL.

    1. Log in to My F-Secure
      • After logging in, if this is your first installation from this account, you will see an option to add device.​Note: If you are reinstalling from this account, you will see your list of devices. Select the device name that you wish to reinstall to and select Release License. A page will appear to confirm the action. Select Release License.
    2. Select Mine or my child's device and click Continue.
    3. The Choose device type window opens. The This computer (Mac) option has been automatically selected.
      • Click Download for Mac. Depending on your browser:The installation file downloads automatically; or
      • You are asked to save the file. If prompted, click Save File.
    4. When the download is done, go to your downloads folder and run the installer (f-secure-anti-virus-for-mac_xxxxxxxxxxxxx_.mpkg).
    5. The Install F-Secure SAFE window opens. Click Continue.
    6. Read the Privacy Policy, and click Continue.
    7. Read the Software License Agreement, and click Continue > Agree to accept the terms of the software.
    8. Select a destination and click Continue. Enter your administrative credentials, if asked, and click OK.
    9. On the Installation Type view, click Install. Enter your administrative credentials, if asked, and click Install Software. The installation process starts and should take less than 5 minutes to complete.
    10. When the F-Secure SAFE activation welcome window appears, click Continue.
    11. In the Name new device window, enter a name for your computer, and click Continue. Enter your administrative credentials, if asked, and click OK.
    12. The Browsing Protection browser extension installation prompts. Choose your browser from the drop-down menu, and click Install now.
    13. Your selected browser opens, and the Browsing Protection extension is now installed.

    Please let me know if you have any further questions about this and please let me know if the problem persists.

    Best regards!

  • Bernard_1958
    Bernard_1958 Posts: 3 New Member

    Good evening,

    Thank you for your reply

    The version that is installed is Sonoma 14.1. I reinstalled the TOTAL application to do the Speed test and I again have a speed problem (63.43 Mbps).

    I use the VPN provided by F-Secure TOTAL connected in Belgium, Brussels.

    I just uninstalled the app. 

    I have started the procedure to install. Download: F-Secure-Safe-Installer_1fcu09an1vsqt_.mpkg.

    I renovated but I still have the same problems: internet slowed down strongly and some protections do not work and gives an error message.

    In addition, now the Chrome browser extension no longer installs.

    What else do I need to do to make the app work properly?

    Thank you in advance for your help,

    Bernard

  • CarolinaC
    CarolinaC Posts: 76 Moderator

    Hello @Bernard_1958 ,

    In this case, I would ask you to turn off the connection to the VPN server and check if the internet speed is still slow when the VPN is off. 

    Have you also tried to change the VPN protocol? Choosing lightweight encryption may help to increase the connection stability as different encryption standards and authentication methods go hand in hand with different levels of speed and security. 

    To change the protocol for your VPN connection please do as followed:

    1. Open F-Secure
    2. Go to Privacy VPN
    3. Go to Settings
    4. Click Choose VPN protocol
    5. Switch between OpenVPN, OpenVPN (TCP) and IKEv2
    6. Turn the VPN protection on 

    I would also like to ask you to connect to another location and see if the connection is also slowed down there. 

    Regarding the Browsing Protection in Chrome did you check if you have not the Browsing protection already installed?

    At the top right, click on the three dots and go to extensions. If you see the F-Secure extension installed there please remove it and try to install it again. 

    If the instructions above do not help to solve the problem, we will try to determine the issue with a diagnostic file. I will send you the instructions later if you get back to me with feedback. 

    Best regards!

  • CarolinaC
    CarolinaC Posts: 76 Moderator

    Hello @Bernard_1958 ,

    I contacted you via private message here on the Community Portal.I need a diagnostic file from your PC to determine the cause of the problem. You will receive the instructions for creating a diagnostic file by private message.

    Best regards.