Activating Freedome causes SSL errors on all websites

maaaaaaaaaaaah Posts: 4 Observer
edited May 2 in F-Secure VPN

When turning on Freedome I get SSL errors on all websites regardless of which site it is. This is when using Sweden as the location. The error on Vivaldi browser is "ERR_SSL_VERSION_OR_CIPHER_MISMATCH". Turning Freedome off makes all websites accessible again. Is there some issue going on?

Accepted Answer

  • Firmy
    Firmy Posts: 1,733 Community Manager
    Answer ✓

    We are delighted to let you know that the issue has been resolved. On Saturday morning, we experienced interference that affected the accessibility of our gateways around the world. Some gateways were completely inaccessible, while others accepted users, however, didn't allow HTTPS traffic.

    We are happy to report that our servers are now functioning as expected.

    It's important to note that even if you encounter the 'ERR_SSL_VERSION_OR_CIPHER_MISMATCH' error, your VPN connection is still established. So, from a security standpoint, you're still protected even if there's an issue with the handshake between our server and the website.

    If you have any more questions or need further assistance, please feel free to reach out. We're here to help.

    Thank you, and have a wonderful day.


  • Muriel_BAILLY_92330
    Muriel_BAILLY_92330 Posts: 1 Observer

    got the same issue with FRANCE location... (I tried all the proposed solution). At the end, I changed the location --> Italy, no more problem, but not a good solution anyway. Could F Secure confirm that the issue will be fixed quickly ?... my subscription will end on the 7th of November, and if it is not fixed, I will not continue with F secure.

  • NatV
    NatV Posts: 19 Enthusiast

    I have the same problem with Denmark and Germany :-(((

  • Brig
    Brig Posts: 1 New Member

    I have same issue on pc and tablet.since saturday 21st. For France and Belgium. This is not acceptable and I hope it will be fixed soon as I have to disable vpn to access internet.

  • PhiloutheCaribbean
    PhiloutheCaribbean Posts: 1 New Member

    I have the same problem on PC, with every web-browser ( Firefox, Chrome, Edge). for France, Finland. Connecting to another location is useless for me .

  • NatV
    NatV Posts: 19 Enthusiast

    I have been using the Oslo server since yesterday. But now this one is corrupt, too. I switched to Zürich which, for the moment at least, seems to work.

    F-Secure, what's going on? Are you subject to some kind of cyber attack? Would be nice if you gave us some information.

  • Firmy
    Firmy Posts: 1,733 Community Manager
    edited October 2023

    Hello @maaaaaaaaaaaah @Muriel_BAILLY_92330 @NatV @Brig @PhiloutheCaribbean

    Welcome to the F-Secure Community. Thank you for your post and comments.

    We regret to hear that you are facing this issue.

    We're currently investigating the matter from our end. It appears to be an intermittent problem, and we're actively working to resolve it.

    To help us in troubleshooting, we recommend trying the following steps:

    1. Reboot the device.
    2. Change your VPN location.
    3. Remove VPN profile.
    4. Change VPN protocol.
    5. Switch your network connection. If you're using Wi-Fi, you can temporarily turn on the hotspot on your mobile device and connect to it. Afterward, switch back to your regular Wi-Fi and see if the issue persists.

    If the problem continues, you might consider uninstalling and reinstalling the app. However, if you're using F-Secure Total, please ensure that you've either exported your passwords or synced them with another device.

    We appreciate your patience and are committed to resolving this issue. If you have any further questions or need assistance, please don't hesitate to reach out. Have a great day.

  • maaaaaaaaaaaah
    maaaaaaaaaaaah Posts: 4 Observer

    Just FYI @Firmy , I'm using this on Win PC with latest Freedome version installed and today it seems intermittent problem. (Yesterday was more a constant problem or so it felt)

    Location changing doesn't help and changing protocol doesn't seem to help either. Am using over ethernet and cable internet connection, so no mobile network involved.

  • NatV
    NatV Posts: 19 Enthusiast

    I'm using a windows PC on Win10 Home Version 10.0.19045 Build 19045, VPN protocol OpenVPN and wifi via mobile router, freedome version 2.64,767.0

    I've experienced performance problems over the last couple of weeks which disappeared when I disabled freedome. The SSL problem or sudden loss of internet connection occurred periodically last week, and close to constant this weekend.

    Changing VPN location doesn't really help, neither does re-booting PC and router nor switching to mobile hotspot/phone and back again.

    I haven't yet tried to shift VPN protocol or uninstall/re-install the app. Need my PC right now and don't want to risk anything.

  • Meddok
    Meddok Posts: 14 Enthusiast

    I have the same issue with two Macs and one iPhone using freedom VPN

  • RGB
    RGB Posts: 1 Observer

    I also get the same problem on Android 14. Yesterday sites and web-related apps were connecting normally. Today (October 22), impossible to use those apps or web sites when VPN is activated (tried France and Belgium)

  • kylehjk11
    kylehjk11 Posts: 2 Observer

    dear @Firmy , don't waste people's time by following ridiculous steps like rebooting devices, redoing the configuration locally etc.. it's not a client problem. It's not a user problem. among other things here, among those who complain you could meet someone who works in the IT service and if not in detail he understood very well that you have serious problems in managing the tunnels. I don't know if it's something about the balancers but you probably can't cut off the hanging connections and everything fills up... in any case I could also be a baker, but here there are people who pay for a service that doesn't work, any location becomes after a while it's unusable and some are actually down, and wasting time by telling you to restart the devices is an insult to those who pay you..🤭

  • SMuck
    SMuck Posts: 1 Observer

    Same problem as @RGB. VPN on = no internet access; VPN off= internet access

    connecting problem:


  • OSX_rulez
    OSX_rulez Posts: 27 Enthusiast

    I have similar issues since updating to iOS 17 on the iPhone (even before there were problems, but less often).

    It happens with different vpn locations.

    Whatever website I need to visit, Safari shows the error "cannot establish a secure connection" , I have already sent many feedbacks through the app.

  • Stockholm
    Stockholm Posts: 1 New Member

    Same for me, started today, Sunday October 23, 2023.

    Doesn't work with Stockholm, get SSL_ERROR_NO_CYPHER_OVERLAP, worked then with Oslo, but now tonight I also get SSL_ERROR_NO_CYPHER_OVERLAP from Oslo.

    Browsers I tested: Edge, Chrome, Firefox.

    Freedom Version: 2.64.767.0, updated, last checked 10/23/2023.

  • Sergeman
    Sergeman Posts: 1 New Member


    I'am from France and i have the same problem 🙁

  • Firmy
    Firmy Posts: 1,733 Community Manager

    Hello @maaaaaaaaaaaah @NatV @Meddok @RGB @kylehjk11 @SMuck @OSX_rulez @Stockholm @Sergeman

    We understand the frustration. We regret the inconvenience caused.

    This issue seems to have arisen due to an issue with one of our VPN gateways, which may have been subject to interference.

    To address this situation, we have implemented a temporary fix. It appears that this problem started on Saturday morning at multiple locations, causing the remaining healthy gateways at smaller sites to become overloaded.

    We greatly appreciate your understanding and patience as we work to resolve this issue. If you have any questions or concerns, please don't hesitate to reach out. Thank you for your cooperation!

  • NatV
    NatV Posts: 19 Enthusiast

    Thanks for updating the community. I admit that I started to worry about the security of my connection. I hope you'll identify the root cause and prevent it from happening again. For what it's worth, the problem started 1 or 2 weeks ago and escalated slowly for at culminate this weekend.

    I am connected to the Falkenstein server now and so far it works fine. I'll let you know if something unexpected happens.

    I chose freedome because I've worked with F-secure professionally and became familiar with you as a reliable company. And I deliberately searched for a European product. Don't let me down.

  • MissPiggy
    MissPiggy Posts: 1 New Member

    Same Problem here, first on Sunday on Win PC, today (Tuesday) on Android.

  • mih
    mih Posts: 1 New Member

    Experienced the problem this afternoon approximately between 12 - 14 local time in Finland. Did lots of troubleshooting, everything up to date including my router and computer, coincidentally rebooting everything seemed to help for a really short while at a time. Even logged in to my router and realized everything was working seemingly fine. As well as every other connected device actually was. Finally after missing the most of an online meeting, I could pin down the culprit that was the VPN functionality in F-Secure Total. Very sneaky, since Windows and F-Secure neither showed connectivity related notifications, and the problem showed at app level. After it was over apparently, I was able to find these threads about SSL errors. Agree with someone who said a more informative service status page would be useful.

This discussion has been closed.
Product & Pricing Info