FreedomVPN —Could not validate the server certificate

Provirtual
Provirtual Posts: 1 New Member
edited April 2 in F-Secure VPN

Hi,

FreedomVPN cannot connect. It says “VPN connection — could not validate the server certificate”.

FYI, I am using an older iPod touch with version 9.3.5. The version of FreedomVPN is 2.7.9.6050. I used to use FreedomVPN years back. So, my iPod still keeps the older version of FreedomVPN.

Can someone help me how I can connect to FreedomVPN? Because it could not validate the server certificate. FYI, I just renewed my subscription. I am so disappointed not able to connect with VPN.

Accepted Answer

  • CarolinaC
    CarolinaC Posts: 74 Moderator
    Answer ✓

    Hello @Provirtual ,

    thank you for contacting us here on the F-Secure Community Portal.

    I am afraid that the issue on the IPod Touch is caused by the outdated Freedome VPN app. The latest version of the app is 3.4.1.8956. In that case I would suggest you to update the app to the latest version. Please also note that Freedome VPN is compatible with iOS version 11 or higher. This means that it will not work on older IOS versions. If you have an iPod Touch (6th generation), you should be able to update to iOS 11, and if you have an iPod touch (7th generation), you can even update to iOS 14. So please check if any iOS updates are available for your device and update the Freedome VPN app after that. 

    Have you also purchased the renewal direct on our homepage? If the app still does not work, we can arrange a refund for you, provided the renewal was purchased from F-Secure within the last 30 days. 

    If you have further questions, I look forward to hearing from you.

    Best regards!

This discussion has been closed.
Product & Pricing Info