How to bypass VPN for certain sites?

Options
batemanj
batemanj Posts: 5 New Member
edited February 6 in F-Secure VPN

Hi,


I've been using Freedome VPN for a while which is working fine. I need to bypass VPN for certain sites so I add a static route for that specific site to bypass VPN which worked fine until the version 2.43.809.


The static route cmd I use: (I use WIFI IP/IF instead of VPN IP in below command) 

route -p delete www.glb.paypal.com. mask xxx.xxx.xxx.xxx xxx.xxx.xx.x IF 22


But with later versions (I tried 2.64.767.0) this VPN bypass is not working any more. It still uses VPN to access those sites.

Pls advise, thanks!!


Edit: PII removed

Accepted Answer

  • PawełP
    PawełP Posts: 286 Moderator
    edited August 2023 Answer ✓
    Options

    Hi @batemanj

    This command you use:

    route -p delete www.glb.paypal.com. mask

     is removing the route. Instead, you should use:

    route -p add www.glb.paypal.com. mask

    Please be careful what service you try to use in there. It seems to be incorrectly configured web service, when we try to enter it with browser, there is a warning about certificate.

    If you still think it is safe site to connect, you can achieve that bypass by enabling killswitch and adding current network as trusted network. This combination of settings allows traffic to bypass VPN tunnel.

    Have a nice day

    Making every digital moment secure, for everyone


Answers

  • batemanj
    batemanj Posts: 5 New Member
    Options

    I tested it on both Windows 10 & 11 and the behaviour is same.

  • ialexhales
    ialexhales Posts: 1 New Member
    Options

    It seems like you're having trouble with the Freedome VPN's static route feature not working as expected in later versions.

    1. Check for Updates: Ensure that you're using the latest version of Freedome VPN. Sometimes issues can be resolved by updating to the most recent version of the software.
    2. Review Documentation: Look through the official documentation or support resources for Freedome VPN to see if there have been any changes or updates to the way the static route feature works. It's possible that there have been changes in the newer versions that affect how static routes are configured.
    3. Contact Support: If you're unable to resolve the issue on your own, reach out to Freedome VPN's customer support. They should be able to provide assistance and guidance specific to your version of the software.
    4. Double-Check Configuration: Make sure that you're inputting the static route command correctly. Check for any typos or mistakes in the command, such as incorrect IP addresses or syntax errors.
    5. Reset and Reconfigure: If you're comfortable doing so, you might try resetting your network configurations related to the static route and then reconfigure it using the latest version of the software.
    6. Try Different Bypass Methods: If the static route method continues to be problematic, consider trying alternative methods for bypassing VPN for specific sites. This might involve using browser extensions, proxy servers, or other tools that can route specific traffic outside the VPN tunnel.
    7. Provide Feedback: If you're certain that the behavior changed in the newer version of the software and it seems like a bug, consider providing feedback to Freedome VPN's developers. They might be unaware of the issue and could work on fixing it in a future update.

    Remember that VPN software can be complex, and behaviors might change from version to version. It's always a good idea to stay updated with the latest software changes and to reach out to the official support channels when you encounter technical issues.

  • batemanj
    batemanj Posts: 5 New Member
    Options

    Thanks ialexhales for the reply.


    1) The problem occurs with latest versions only (not with some older version as mentinoed in my OP)

    2) checked, can't see any changes related to it.

    3) will do if no luck with forums here.

    4) static route command is correct as it worked perfectly fine with older version. There's no error when I run this command even with new version of Freedome VPN, its just that the static route is not working (still uses the VPN)

    5) Tried but no luck.

    6) Proxies and other alternatives are not option.

    7) will do. I think it's some bug in the latest versions are this feature disabled in latest versions? Appreciate if some product support confirms the same.

  • batemanj
    batemanj Posts: 5 New Member
    Options

    Hi PawelP, thanks for the reply.

    Yeah I used "route -p add" (not delete, i pasted wrong command) and the correct website. These commands worked fine with old version of VPN.

    You mentioned "You can achieve that bypass by enabling killswitch and adding current network as trusted network. This combination of settings allows traffic to bypass VPN tunnel." It's not very clear to me as I'm not using any kill switch atm. Could you pls point me to any doc/URL so I can refer to achieve it.

    regards,

  • PawełP
    PawełP Posts: 286 Moderator
    Options

    Hi @batemanj

    Hi

    When writing about Killswitch, I was referring to the property in the VPN FREEDOME Program.

    You can find more about it at this link:

    https://help.f-secure.com/product.html#home/freedome-windows/latest/en/id_110707-latest-en

    I hope this will be helpful. 

    Have a good day

    Making every digital moment secure, for everyone


This discussion has been closed.
Product & Pricing Info