F-Secure extremely slow scanning on Android phone

Options
jnnh73
jnnh73 Posts: 8 Explorer
edited November 2023 in F-Secure Total


I used to have F-Secure installed on my phone. Then I uninstalled it and tried another product for a while.

Now I reinstalled it and it is much slower than it used to be.

When I previously used it, it started to scan automatically when I rebooted my phone. It took a few minutes.

Now, ever since the reinstall it takes about 100-120 minutes to scan. It is so slow it is extremely annoying, and it does it on every reboot!

When I try to cancel it, pressing "cancel" does absolutely nothing, it just continues scanning.

I tried to delete cache, no help.

I also tried to reinstall it twice, no help.

I am using Samsung A52s with Android 13, latest version of UI and the latest (April) security patch.


Any help would be appreciated, how to make it work as fast as it was working before I foolishly removed it. Is there still something I need to clean - remove - tweak etc.

Thank you.



EDIT:

I solved this, kind of. So I was a bit too hasty posting this.

I didn't even think of disabling WIFI because all the others apps worked just fine and I had no connection issues of any kind.

But when I reinstalled F-Secure and turned off WIFI, it now scans my device in less than a minute!


So it is fixed, but still I don't quite understand why it does that, since my WIFI connection works just fine with other apps, there are no connection issues. A bug in the program?


But I'm happy with this, since my mobile data is unlimited and I don't have to pay any extra, I can just keep my WIFI OFF.

Accepted Answer

  • Ukko
    Ukko Posts: 3,640 Superuser
    edited May 2023 Answer ✓
    Options

    Hello,

    I am only an F-Secure user.

    Indeed strange situation. More than hour to scan in Android app is something 'unexpected'.

    When I previously used it, it started to scan automatically when I rebooted my phone

    ...

    Now, ever since the reinstall it takes about 100-120 minutes to scan. It is so slow it is extremely annoying, and it does it on every reboot!

    Probably the answer is 'yes', but did you try to run manual scan (not autoscan after reboot)? Is this type also with such 'state'?

    When I try to cancel it, pressing "cancel" does absolutely nothing, it just continues scanning.

    Very strange too.

    Could you clarify some points:

    • why scanning is so long? I mean, percentage is going with some stable speed OR there is stuck at the some percents? How many files are scanned at the end?
    • despite pressing "cancel"-button - scan then described as completed? Or after some 'continues scanning' minutes - it is canceled? So, took faster than fully completed process. Or trying to cancel is completely useless?

    I am not sure how scanning is designed in Android, but probably there two main things: calculating hash (of files/items) and communicating with F-Secure Security Cloud.

    It is good to understand what the trouble there. Network-based or something local. Also, is trouble about general scanning or only certain items.

    I am using Samsung A52s with Android 13, latest version of UI and the latest (April) security patch.

    All was fine with this device (Android 13)? Or there was another Android version at the time when you used to have F-Secure installed on your phone?

    Any help would be appreciated, how to make it work as fast as it was working before I foolishly removed it. Is there still something I need to clean - remove - tweak etc.

    If this trouble can be reproduced with any Network connection; Any scan-types; There are no tricky/large files (or something, which is the main time consumer) and it is not something known about Android 13 - then you can try to use this feature:

    I am not sure if this is the most 'reliable' way, but.. at least, some logs/information can be analyzed.

    Thanks! // and sorry for my English.

Answers

  • jnnh73
    jnnh73 Posts: 8 Explorer
    edited May 2023
    Options

    Hi, and thank you for answering / tips.

    I edited my post a while ago, it seems that it works fine now with mobile data ON and WiFi turned OFF.

    As my mobile data is unlimited it does not matter, it does not cost any extra. It is just a bit weird. Maybe it was a temporary glitch, it could start working just fine with it as well.

    But now it seems to be OK, with WiFi off the initial scan took less than a minute.

    Before that it did progress, it wasn't stuck, but it just progressed... very... slowly.


    EDIT: OK, now it seems that after turning my 4G modem and phone off for a while, it now scans fast with WiFi on as well. It was the initial scan after installation that caused issues, and took almost forever. It never quite went to 100%. Tried several times, rebooted the phone, tried again and so on.

    Now all seems fine, let's hope it stays that way :)

This discussion has been closed.