"The application cannot open the specified document or URL

pawelbb
pawelbb Posts: 3 New Member

Hi!

I just installed the F-secure safe on my Macbook Air with M1 processor. I live in Finland and was happy to hear that the local boys finally got the F-secure to run natively on M1.

However...

After I installed it, when I tried to run a scan or proceed with safari browser extensions installation, I got hit with an Apple Finder error saying:

The application “TerraformingMars” cannot open the specified document or URL.

Well, I do have Terraforming Mars on my computer, but what does it have to do with F-secure? It appears after I click the buttons within F-secure app. Any solutions?

Best,

Pawel

Accepted Answer

  • ArthurVal
    ArthurVal Posts: 173 F-Secure Employee
    Answer ✓

    Hi, @pawelbb!

    Thanks for report. That's indeed a known issue on macOS side. We have been discussing it with Apple and found a solution that will be included in the upcoming mid February product update.

    Long story short, some button clicks in the main UI window ask the operating system to locate the appropriate app to handle the corresponding action. But for some reason, macOS makes the wrong selection when it tries to resolve the handler app.

    In the meanwhile, launch scan and browser extension installation actions can be invoked from the menubar app icon. Click on the product icon in the menubar area (upper-right side of the screen). From there, you can launch a full system scan or choose a specific location to scan.

    You can also access "Preferences..." from the dropdown menu and install browser extensions by navigating to "Secure Browsing" settings tab.

    Best regards, Arthur

    Mac R&D Team

    Firmy

Answers

  • pawelbb
    pawelbb Posts: 3 New Member

    Just gonna add, the same happens if I click "Help" or "Contact support" ...

  • pawelbb
    pawelbb Posts: 3 New Member

    Yes. So as soon as I uninstall "Terraforming Mars" through steam, F-secure suddenly works as it should. Reinstallation invokes the problem again. I tried even unistalling both, first installing F-secure and then Terraforming Mars. Still same issue.

Pricing & Product Info