F-Secure SAFE super high memory usage

Jkyzer
Jkyzer Posts: 4 Observer
edited January 8 in F-Secure SAFE

About a month or so recently after the update, fshoster64.exe would use up a lot of memory and had to be rebooted before it would be resolved, but it would continue to happen after running for a while.

The operating system has been completely reinstalled, excluding other software problems

Provide fsdiag.zip as analysis



Edit: PII removed

Accepted Answer

  • Firmy
    Firmy Posts: 419 Moderator
    Answer ✓

    Hello @Jkyzer

    Welcome to the F-Secure Community page. Thank you for your post.

    I have removed the FSDIAG you posted earlier to protect your privacy.

    As I quick fix, I would suggest you uninstall F-Secure SAFE by using the Uninstallation tool and reinstall it back. You can do the following uninstall using the tool and reinstall. Kindly select to remove F-Secure SAFE only, or else, it will remove all F-Secure products installed on your machine.

    Uninstallation:

    1. Log on to your computer with administrator rights.
    2. Download the Uninstallation Tool for Windows from our Support Tools page.
    3. Run the executable UninstallationTool.exe.
    4. Click Yes.
    5. Click Start.
    6. Select the product or components you want to remove and click Next to initiate the uninstallation process.
    7. Click Restart when prompted to remove the remaining files.

    The uninstallation is complete when your computer restarts.

    Reinstallation:

    1. Log into your My F-Secure account: https://my.f-secure.com/login
      • ​​​If you are unable to access the account or forgot your password, click on the Forgot Password option and type in your email address for a reset link to be sent.
    2. Select the device name that you wish to reinstall and click Release License.
    3. A page will appear to confirm the action. Click on Release License. The license is now removed. 
    4. Click + Add device.
    5. Choose My deviceMy child's Device or Someone else's device
    6. Select the device type (the system recognizes your device type by default) and click on Download for Windows.
    7. Once the download is completed, run the F-Secure Safe Network installer.
    8. When the installer launches, click Accept and Install

    The installation will uninstall the previous version/installation and will require a restart. The process usually takes a few minutes or so, and once installed, your computer is protected.

    Kindly let me know if this helps.

    Thank you and have a good day.

    zaimazmi

Answers

  • Jkyzer
    Jkyzer Posts: 4 Observer

    I'll try it again.

    Maybe it will take a few days to observe.

    Never seen this on any device I've owned in the past few years.

    Anyway Thx.

    I will reply if there are any updates.

    zaimazmi
  • Jkyzer
    Jkyzer Posts: 4 Observer

    Okay, I tryed again reinstall , The Result is dosen't have any change.

    But good news is I find who make this issue happing.

    I almost confirm this problem it's caused by F-Secure SAFE's browser plugin "Browsing Protection by F-Secure".

    When I disable it in my browser than keep observe,

    one day later,fshoster64.exe this program memery usage back to normal, probably like 600~700MB total and dosen't have anymore unidentified memory occupancy.

    Maybe I'll try reinstall plugin or check if there is a conflict with other plugins later.

    zaimazmi
  • Firmy
    Firmy Posts: 419 Moderator

    Hello @Jkyzer

    Thank you for your comment.

    I reviewed your FSDIAG sent by you earlier and found that you have an AdGuard extension installed.

    We believe this might cause the issue, kindly turn off the extension and check if the issue persists.

    Kindly let me know what you find after turning off the AdGuard.

    Thank you and have a good day.

    zaimazmi
  • Jkyzer
    Jkyzer Posts: 4 Observer

    Hi , I tried enabling F-Secure SAFE's Browsing Protection plugin with disable Adguard's plugin same time.

    After observing it for a while, there is indeed doesn't have issue.

    But the weird thing is when I turn adguard's plugin back on,I can't reproduce that issue now.

    Maybe is get some database or program update to fix it.

    Anyway , I'll keep, observe and try how to reproduce it, I will reply if have any new findings.

    Thanks.

    Firmy
Pricing & Product Info