Freedome VPN not working

userx1907 Posts: 3 Observer
edited February 2023 in F-Secure VPN

Hey ,

I formatted my MAC os computer.

I downgraded Monterey from mojave version.

While it works fine in the Monterey version, Mojave also stays on this screen and does not improve for hours.

I remember making some network settings in the Monterey version, but the program prompted me.

I tried many different locations.


Accepted Answers


  • Amirul
    Amirul Posts: 161 F-Secure Employee

    Hi @userx1907

    Thank you for reaching out to F-Secure Community.

    Our team is investigating this issue as it only happens on F-Secure Freedome VPN installed on macOS 10.14 and older, it does not affect another operating system for now. The version that causes this issue is Version 2.52.322.0. If you have this version on your device, you may be affected by this.

    I will sent you a private message to get some information to escalate this issue accordingly to our team.

  • Troy
    Troy Posts: 3 Observer

    I having the same issue. I'm on 10.14. It stopped working for me. What do I do? I recently installed the updated version of the VPN software. When I did, it just spins trying to connect. I've restarted the computer and application multiple times without any success. What are the next steps?

  • RocailleBox
    RocailleBox Posts: 9 Explorer

    I've got the same issue. I'm running Mojave 10.14.6 (not ready yet to install Monterey).

    I have uninstalled and re-installed it several times. I even released a license one time. But it just simply won't connect to a VPN, not even in my home country.

  • mikkryt
    mikkryt Posts: 5 Observer

    same here i have imac high sierra versio 10.13.6

  • RocailleBox
    RocailleBox Posts: 9 Explorer



    Did a cold reboot.


    Released the prior license (did you forget about that part?)

    Still trying to connect to a VPN as I 'm writing this.

  • Jaims
    Jaims Posts: 846 Former F-Secure Employee

    Hi @RocailleBox

    Thanks for the feedback.

    Yes, releasing the previous license is needed for a TOTAL subscription but not required for a standalone FREEDOME subscription. That comment has now been edited to accommodate both types. Thank you.

    Our team is still investigating why the issue persists after reverting to the older version. We will get back to you shortly, please bear with us.

  • RocailleBox
    RocailleBox Posts: 9 Explorer


    I released the Freedome license because my computer ended up having multiple licenses.

  • Jaims
    Jaims Posts: 846 Former F-Secure Employee
    edited July 2022

    Hi @RocailleBox @userx1907 @Troy @mikkryt

    Please download the fixed package of Freedome VPN v2.53.324.0.pkg from this link

    Do let us know the outcome of this new installation.

    Thanks for your cooperation and understanding.

  • RocailleBox
    RocailleBox Posts: 9 Explorer


    Thanks for being on our case! :-)

    Link is not working properly. All I see is 5 blue dots fading in and fading out at the top of the screen.

  • Firmy
    Firmy Posts: 1,621 Community Manager

    Hi @RocailleBox

    Thank you for your reply.

    Kindly try again to access the link.

    It should be fine now.

    Kindly let us know if the issue is resolved.

    Thank you and stay safe.

  • RocailleBox
    RocailleBox Posts: 9 Explorer


    Still the 5 dots dancing in and out of existence...

  • AnonVonZilch
    AnonVonZilch Posts: 2 Observer

    After a few tries the link worked for me, but then the download button does nothing.

  • userx1907
    userx1907 Posts: 3 Observer

    Hi @Jaims

    I was able to download using different browser. I did the installation and my problem was solved. works well

    Thank You !

  • RocailleBox
    RocailleBox Posts: 9 Explorer

    @userx1907 @Jaims

    Tried it with Safari. Same 5 dots.

    What browser have you used. At first it was Firefox.

  • Avanaut
    Avanaut Posts: 1 Observer run my Mac on old 10.12. Everything worked until recent Freedome update to version 2.52.322.0. I now get this same message (Connecting... ON) as the OP.

    Tried to download fixed package as provided but the download does not work.

    How to fix this?

  • RocailleBox
    RocailleBox Posts: 9 Explorer

    @Jaims @Firmy Why don't you upload the package to some reputable upload site or something, please?

  • RocailleBox
    RocailleBox Posts: 9 Explorer

    I'm throwing in the towel and upgrade to Monterey. It wasn't all bad. Learned how to find, backup and delete unecessary huge files to prepare for the upgrade.

  • RocailleBox
    RocailleBox Posts: 9 Explorer

    Upgraded to Monterey. Now it works and my task is to change that pesky look.

    Thanks, anyway!

This discussion has been closed.
Product & Pricing Info