Website blocked in Firefox, working fine in Microsoft Edge

astroebel
astroebel Posts: 2 New Member
edited June 16 in F-Secure SAFE

Hi,

F-Secure blocks the site https://www.schwaebisch-hall.de/mein-konto.html in Firefox, whereas it works pretty fine in Microsoft Edge. It's a banking website.

Moreover, once the site was blocked, many other sites in Firefox are blocked, including F-Secure.

Anyone any idea?

KR, Andreas

Accepted Answer

  • Firmy
    Firmy Posts: 293 Moderator
    edited June 23 Answer ✓

    Hi @Rockyrider @janeg @astroebel

    We have released the new version of browsing protection by F-Secure for the issue of banking and browsing protection on Firefox. The latest version of the extension is 4.1.39.

    Kindly check the version on your Firefox.

    Step 1

    • Check the version of browsing protection by F-Secure
    1. Click on the 3 bar at the top right-hand-side of Firefox
    2. Select Add-ons and themes
    3. Find Browsing Protection by F-Secure
    4. Select the 3 dots at the browsing protection by F-Secure
    5. Select manage
    6. Check the version installed

    If the version is 4.1.39, you may go to your online banking website and check if the issue remains.

    If the version is 4.1.36, kindly select remove by clicking on the 3 dots at browsing protection by F-Secure to reinstall.

    Step 2

    • Reinstall browsing protection by F-Secure
    1. Open F-Secure program
    2. Go to Secure Browsing & Banking
    3. Scroll down to the Browser extensions section
    4. Click Install Firefox extension

    Note: If the page is blank, select the address bar with the address https://download.sp.f-secure.com/online-safety/fs_firefox_https.xpi and press Enter on your keyboard to refresh the page.

    Once done, check if the browsing protection by F-Secure is installed on Firefox by following the steps on how to check the version of browsing protection by Firefox in Step 1. 

    If the browsing protection by F-Secure is still missing on Firefox, repeat Step 2 (Reinstall browsing protection by F-Secure) until you have accepted the privacy.

    Kindly let me know if this helps.

    Thank you and stay safe.

    JaimsUkkoAmirul

Answers

  • janeg
    janeg Posts: 2 New Member

    Same issue - with two financial sites but a third is fine. Get blocked when I try to access them.

    Firefox (have not tried another browser).

    Looks like Browsing Protection by F-Secure was updated to version 4.1.36 today (June 16, 2022) so I'm guessing something about this new version? I was on my bank websites June 14 th and I had no issues accessing the sites.

    Also had the same issue of other sites being blocked - was kicked off F-Secure when I was writing this comment

  • Amirul
    Amirul Posts: 125 Moderator
    edited June 17

    Hi @astroebel and @janeg

    Thank you for reaching out to F-Secure Community.

    Currently, we are aware of this issue and our team is in the midst of gathering the necessary information to aid the resolution. As of now, this issue only happens on the Mozilla Firefox browser but it is not affecting all the banking sites. If you can provide the other affected banking sites getting the same error, I will forward this to our team so that they can check accordingly.

    Once I have more information on this, I will update this post. Thank you again for your patience and support.

    FirmyJaims
  • Rockyrider
    Rockyrider Posts: 11 Observer

    Bank of Scotland is the same and National lottery, something is broken in Firefox and very annoying?.

  • Reynardo
    Reynardo Posts: 1

    Add the Fandom Wiki site as well. https://www.fandom.com/

  • Amirul
    Amirul Posts: 125 Moderator
    edited June 18

    Thank you @janeg @Rockyrider @Reynardo for the reply.

    I just received an update from our team with regards to the issue. After gathering all the information, F-Secure has decided to roll back to the previous version of Browsing Protection by F-Secure on Firefox. This may take a few hours before it gets to the customer's end. The new version that was released is Version 4.1.36 and it will be rollback to Version 4.1.20. If you were unable to get the rollback update, try to remove and re-add the extension again.

    Another option will be to use Google Chrome or Microsoft Edge, this two browser is not affected by this issue only Firefox.

    Our team is still investigating this issue and it is not affecting all the bank sites but a few of them only. Once there is any news, I will update this post.

    Thank you all for your patience and support.

    FirmyJaimsUkko
  • Rockyrider
    Rockyrider Posts: 11 Observer

    At the moment the link to get the extension in f-secure safe doesn't work and when you go to firefox extensions to install, it installs version 4.1.36 which is causing the problems?.

  • Rockyrider
    Rockyrider Posts: 11 Observer

    Browsing protection in firefox is totally broken says the code is not valid, it does not exist in their gallery so I'm assuming they have removed it. Link in f secure settings does nothing, is the problem firefox or f secure, would be good to know before uninstalling either?.

  • Rockyrider
    Rockyrider Posts: 11 Observer

    The workaround for me doesn't work because the code is invalid according to Firefox?. it needs new code.

  • Firmy
    Firmy Posts: 293 Moderator

    Hi @Rockyrider

    May I know what code are you looking for? Can you provide us with a screenshot of the error?

    Thank you and stay safe.

    JaimsAmirul
  • astroebel
    astroebel Posts: 2 New Member

    Hi @Firmy ,

    for me this workaround works! I can connect to my online banking now as needed.

    Many thanks!

    JaimsAmirul
  • Rockyrider
    Rockyrider Posts: 11 Observer
    edited June 22

    ...... this is the authorisation cone in autofill in secure f id protection, its not working for me, edge and chrome are fine but not Firefox


    Edit: PII Removed

  • Rockyrider
    Rockyrider Posts: 11 Observer

    Should be code not cone, sorry.

  • Amirul
    Amirul Posts: 125 Moderator
    edited June 22

    Hi @Rockyrider

    Thank you for your reply.

    This is an authorization code for the auto-fill features of F-Secure ID Protection. This is related to the extension Password Manager by F-Secure. You may read the information below on how to install and authorize the autofill browser extension:

    Installing and authorizing the autofill browser extension | ID PROTECTION | Latest | F-Secure User Guides

    You also have an open case with us regarding the issue mentioned above. Should you need any assistance, you can reply to the email and our support will help you further on this issue.

    Password Manager by F-Secure and Browsing Protection by F-Secure is a different extensions for different purposes. Hope this answer your inquiry.

    FirmyJaims
  • merula31
    merula31 Posts: 7 Observer

    When trying to log in to PayPal today, I was hit by this problem (Firefox with F-Secure extension 4.1.36). The PayPal home page was reachable; but on the attempt to log in, the login page flashed up only for a very short moment and was then immediately replaced by a rather bland "F-Secure -- Webpage denied" page, with "h-t-t-p-s: //192.xxx.yyy.1/resourceaccesstoken"  (an IP address belonging to Intel Corp.??) as the only additional info. No further explanation or guidance.

    The advice in the post above ("Accepted Answer") "basically" worked, only it did not revert the F-Secure extension to 4.1.20 as advertised but instead updated it to 4.1.39.

    That's of course good, and it solved the problem for me. But it also added to the confusion (one would expect such essential info and advice, if one happily has found it, to be up to date...?)😏

    In the same vein, may I suggest to add to that rather laconic "Website denied" page some Help button, or a link with pointers to further information and support? Without that one feels a bit at a loss, and having then to dig through the forums etc without specific guidance is not an easy task. (Or is there such a link and I missed it?).

    Still, all's well that ends well.

    m.

  • Amirul
    Amirul Posts: 125 Moderator

    Hi @merula31

    Thank you for your reply.

    The advice in the post above ("Accepted Answer") "basically" worked, only it did not revert the F-Secure extension to 4.1.20 as advertised but instead updated it to 4.1.39.


    That's of course good, and it solved the problem for me. But it also added to the confusion (one would expect such essential info and advice, if one happily has found it, to be up to date...?)😏

    We did roll back our Browsing Protection extension on Firefox to version 4.1.20 due to the issue on version 4.1.36. The rollback decision was made to ensure that our customers still get protection on their Firefox browser. Alternatively, users still can use Chrome or Edge to access the banking site as this two are not affected by the issue.

    After fixing the issue, our team decides to release the new version 4.1.39 which fix the issue that happens in the previous version. Hence you getting version 4.1.39 instead of 4.1.20.

    In the same vein, may I suggest to add to that rather laconic "Website denied" page some Help button, or a link with pointers to further information and support? Without that one feels a bit at a loss, and having then to dig through the forums etc without specific guidance is not an easy task. (Or is there such a link and I missed it?).

    We appreciate your feedback and suggestion. From time to time, we will always try to improve our product either on the technology that we use and not forget to improve customer experience on the product. Feel free to share your idea with our team by posting your idea in the link below:

    Feature Requests — F-Secure Community

    FirmyJaims
Pricing & Product Info