F-Secure SAFE fails with error message Event ID 11722 (error 1722) Action InstallLateboundPackages

AndiL
AndiL Posts: 2 New Member
edited March 22 in F-Secure SAFE

Installation is not working on notebook running Windows 7 with latest hotfixes. OS eventlog record appears (see attachment). F-Secure SAFE installation passes on second notebook with Win7 and hotfixes without problem. Unknown what difference causes setup to fail.

On failing system I tried:

Windows Installer service is running automatically - same failure

Run msiexec /unregister and msiexec /regserver - same failure

Check running msiexec version - is 5.0

Delete C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys directory - same failure

Run FsUninstallationTool.exe - same failure

Run MicrosoftProgram_Install_and_Uninstall.meta.diagcab - tool did not discover any issue

Any idea what to do to solve this issue?


NOTE : Text file remove as the information is considered as PII

Accepted Answer

  • Amirul
    Amirul Posts: 56 Moderator
    Answer ✓

    Hi @AndiL

    Thank you for the update.

    This would be the next steps of troubleshooting that I can suggest to you related to the issue:


    A previous or failed F-Secure product installation can cause the installation to fail at the very end. Check your Application Event log for the MsiInstaller error Event ID 11722:  

    Product: F-Secure SAFE -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action Ultralight_Install, location: C:\Program Files (x86)\F-Secure\SAFE\\UltralightInstaller\ul_5420.exe, command: --aua-mode=true --install-directory="C:\Program Files (x86)\F-Secure\SAFE\Ultralight\\" --product-directory="C:\Program Files (x86)\F-Secure\SAFE\\" --doorman-url=dummy --doorman-id=dummy --doorman-hash=dummy 

    If you see similar error in your Application event log, follow the steps below to try to fix the issue:

    1. Download the F-Secure Uninstallation Tool for Windows and remove all F-Secure products using it: https://download.sp.f-secure.com/uninstallationtool/FsUninstallationTool.exe
    2. Restart the computer after running the tool
    3. Search for Regedit with the Windows Search tool and run the Registry editor
    4. Navigate with the Registry editor to folder HKEY_LOCAL_MACHINE\SOFTWARE\F-Secure\ 
    5. Right-click the F-Secure folder and delete it
    6. With the Windows File explorer, remove the following folder if it exists:
      • C:\Program Files (x86)\F-Secure\
    7. Restart the computer
    8. Try the installation again 


    If the above did not fix the issue, follow the workaround below to try fix the installation issue:

    1. Rename following files to anything else (e.g. vcruntime140_old.dll):
    • On 64 bit Windows: 
      • C:\Windows\SysWOW64\vcruntime140.dll
      • C:\Windows\SysWOW64\msvcp140.dll
    • On 32 bit Windows:
      1. C:\Windows\System32\vcruntime140.dll
      2. C:\Windows\System32\msvcp140.dll
    1. ​​Restart the computer


    If the steps above do not help, there is a possibility that registry key HKEY_USERS\S-1-5-20 doesn't have the required permission for NETWORK SERVICE and fsnethoster is unable to create an entry there.

    Follow the steps below to fix the issue:

    1. Click Start
    2. Type regedit, and press Enter
    3. Navigate to and select registry key HKEY_USERS\S-1-5-20
    4. Select Edit
    5. Select Permissions
    6. Click Add...
    7. Type NETWORK SERVICE (if you are using a non English version of Windows, this name will be different. In German for example it is Netzwerkdienst)
    8. Click Check Names (the name should get underlined)
    9. Click OK
    10. Check Allow checkbox for Full Control (also Read permission should be automatically allowed)
    11. Click Apply
    12. Click OK

    NOTE! Also, make sure that HKEY_USERS\S-1-5-20\Software -key has the same permission as the  HKEY_USERS\S-1-5-20.

    JaimsUkkoFirmy

Answers

  • Amirul
    Amirul Posts: 56 Moderator

    Hi @AndiL

    Thank you for reaching out to F-Secure Community.

    Some information is being remove on your post as it contains personal information related to your device.

    As of the issue that you are facing with your Windows 7 computer, I would like you to install these update (KB4474419) by Microsoft in order to install F-Secure SAFE on Windows 7 SP1 device. You may download the update on the link below depends on your operating system type:

    Once you have download and install it, you can try to re-install the F-Secure SAFE again.

    JaimsUkko
  • AndiL
    AndiL Posts: 2 New Member

    Hi Amitrul,

    thanks for your proposal. But KB4474419 was first thing I installed. But it does not solve the problem. I even did an update to latest MS hotfixes. But setup still fails with same error at approximately 99%: "Something went wrong..."

    Ukko
Pricing & Product Info