ID PROTECTION keep asking Master Password used in another device

System Posts: 137 Enthusiast
This discussion was created from comments split from: ID PROTECTION keep asking master password used in another device.

Accepted Answers

  • tml63
    tml63 Posts: 7 Explorer
    Answer ✓


    I finally exported my paswords, uninstalled the application from all machines and started from fresh installation by importing the passwords. That finally solved my problem.

  • Jaims
    Jaims Posts: 846 Former F-Secure Employee
    Answer ✓

    Hi @jhumphr

    Many thanks for your swift response.

    Please try to turn on the old PC and see if the Master Password works there. If the result is positive, syncing from this PC to the mobile device should be possible but if not, then it's advisable to reinstall IDP on all devices from scratch then import the passwords (the one you exported earlier) then start from there.

    Here is the guide:

    1. Uninstall F-Secure ID Protection: User Data from Add/Remove programs list of Windows (or possibly F-Secure KEY: User Data if the software was upgraded from F-Secure KEY). You can also use this Uninstallation Tool then choose the second option by manually choosing IDP and IDP User Data so it does not remove SAFE and Freedome VPN if you have them installed but if not, just choose the first option to remove all F-Secure products.
    2. Install F-Secure ID PROTECTION on other devices and connect them with the one installed on the old Windows PC or from the new installation
    3. Unlock F-Secure ID PROTECTION and Import the previously exported passwords back to this newly activated F-Secure ID PROTECTION on your PC
    4. Open F-Secure ID PROTECTION, go through the activation flow and create new master password

      Thanks for your patience, cooperation and understanding.


  • User_20647
    User_20647 Posts: 2 New Member

    Hi @Jaims

    I have exactly the same problem, impossible to sync between my Android IDP app and desktop IDP app. It started when my mobile got broken and I had to install ID Protection to another backup phone (OS is Android 9). When installing IDP to the backup mobile, the problem started when I tried to use the fingerprint option for opening it.

    I tried your solution, so to uninstall IDP from the mobile phone and reinstalling it. But after the installation, you must set up a new password or sync, there is no "forgot password option". So when I created a new password, logged out, clicked "forgot password" and scanned the recovery code from my actual IDP desktop app where all my passwords are, I got the error "wrong recovery code" scanned. Because apparently the mobile IDP app expected to see the recovery code generated from the mobile app which had 0 passwords in it.

    Now the Desktop app also keeps nagging all the time with a popup "type in the master password in the other app" and when typing it correctly, it's not accepted.

    What else can I try?

  • Jaims
    Jaims Posts: 846 Former F-Secure Employee

    Hi @tml63

    I am delighted to know that the instruction helped solve the problem.

    Ensure you maximize the full potential of F-Secure ID Protection by installing it on more than one device just in case one of the devices gets damaged or stolen. You can be certain of having your passwords intact and ready to sync again.

  • Cale
    Cale Posts: 288 F-Secure Product Manager

    @User_20647 , you said "But after the installation, you must set up a new password or sync" - If I followed your flow correctly, here you should pick the sync option and generate a sync code with the desktop app. After you enter that to the mobile app, it will ask for the desktop app master password.


  • User_20647
    User_20647 Posts: 2 New Member

    Hi @Cale

    so @Jaims proposed as solution to scan the recovery code after reinstalling the Android app. But this advice is useless because you can't scan the recovery code when you take the ID Protection into use. You can only sync or or set up a new password. Of course I tried to sync it but the master password is not accepted!

    I've tried removing and reinstalling the Android app but the master password is not accepted during the sync. I've now had Key/ID Protection during 8 years and always with the same master password. So I'm 100% sure that I have typed it in correctly.

    I now have the same problem with my previous Android phone (Android 11 (Samsung A71) ), it was broken but is now functional again. I installed ID protection on it but when trying to sync it with the desktop app, and when giving the desktop app's master password on the Android, it's not accepted!

    So I can't now use ID protection in my Android phone at all which is a pain.

    Additionally, every time I open my desktop app from scratch (using the master password), I get a popup, which says that I should give the master password in the other device. And I'm not even trying to sync in the other device but just opening the desktop app, e.g. after a laptop reboot:

    So it seems that the syncing function is somehow active all the time in the desktop app and keeps on nagging. The master password is never accepted in any device.

    To get rid of this annoying popup, I even tried uninstalling the Android app from both of my Android devices but the desktop app keeps continuing to ask the master password "for the other device". Which is weird because originally I tried to sync the passwords from the Win desktop towards the Android app and not vice-versa.

    I know how the sync functionality works, as I've used it for many Android devices. And this one is a new bug that I have never encountered and can't resolve. It really started when I took my older Android 9 device (Samsung A8) into use as as a replacement, because my Android 11/Samsung A71 got broken, and when setting up the ID Protection to use the fingerprint feature on the Android 8.

    I thought that the app would start working with my Android 11 (Samsung A71) now that I got it back from reparation but the syncing doesn't work, the desktop app's master password is not accepted. And the desktop app keeps nagging with the above popup.

    The end result is that I can't use ID protection on my Android devices.

  • jhumphr
    jhumphr Posts: 3 New Member

    Just chiming in, to say I have the same issue, and to provide more insight.


    Android OnePlus 7 Pro model GM1913 running Oxygen OS (not rooted)

    Windows 10 Pro 64-bit (10.0, Build 19042). System Model: MS-7B12; BIOS 1.70. 128GB RAM.

    Both devices had several GB of spare disk space.

    Here is what happened:

    1) I attempted to open my ID PROTECTION vault on Android, authenticating with fingerprint. THIS CAUSED THE APP TO SPONTANEOUSLY CLOSE.

    2) I re-opened the app, and attempted to open my ID PROTECTION vault on Android, authenticating with fingerprint. IT CLAIMED THE PASSWORD WAS INCORRECT. (A bizarre error considering I was using my fingerprint.)

    3) I tried to enter my Master Password via the keyboard. It claimed the password was incorrect.

    4) I tried to use my recovery QR code. It said it was the wrong QR code.

    At this point can we appreciate how incredibly unacceptable this is. If I didn't have my passwords synced to other devices, I would have just permanently lost access to all my passwords. This could be critical business data. This could be valuable cryptocurrency. etc.

    5) I attempted to open my ID PROTECTION vault on Android, authenticating with Master Password. This was successful, but then tried to get me to update to a new password - allegedly the password had been changed on another device!

    At this point it becomes clear that a glitch (or malicious actor) has changed the password on my Android app. Probably a glitch relating to fingerprint authentication.

    6) Thankfully I can click 'cancel' and continue to use the app as normal.

    7) I export a plaintext copy of my passwords, becuase I cannot trust F-Secure to be functional and reliable any more.

    8) I change the Master Password on my desktop. This does not help; the password is still incorrect on Android and I still get these demands to enter the master password used on another device.

    9) I uninstall and re-install ID PROTECTION on Android, making sure to clear the app data and cache.

    10) I log into my account on Android. My device is not recognised; I must add it as a new device.

    11) I attempt to re-sync my Android app, using a sync code generated on my Desktop app. But the Master Password is still not accepted. I am stuck on the screen shown below. (Yes, I tried the old and new Master Passwords.)

    12) I find this thread and attempt to use it to support in resolving the problem. But there is no way to even try and use a QR recovery code, because I cannot get past the above screen. So the advice is useless.

    In summary, the android app has encountered some kind of glitched state which locked me out of my passwords, failed to recover, and the issue persists when the app is wiped and reinstalled.

    Please do take it seriously when I say that I find this issue both frustrating and deeply concerning. If I cannot trust the cyrptographic robustness of your app, how can I continue to use it? I also have been recommending to my family to use this app too; so far my spouse and both my parents have accounts with paid subscriptions, but unless there is satisfactory resolution to this issue, I will have to spend several hours migrating over to a difference service, and then recommend that my family do the same.

  • Jaims
    Jaims Posts: 846 Former F-Secure Employee

    Hi @jhumphr

    Sincerely apologize for the issue you are facing and sorry all the trouble.

    I am not sure if you released the license of this Android device from the portal after the uninstallation as it appears to have reflected twice. I have sent you a private message naming these 2 licenses. Kindly release those items then perform the reinstallation again. For the first time setup, please enter the Master Password and later you may try to use the fingerprints on subsequent logins.

    I would not suggest making any alteration to the desktop app since it's not the one with the issue now. If everything works fine, backing up the password is although a good idea but the focus should entirely be on the android device.

    If the issue persists, we will like to reproduce the issue on this OS so we might follow up with you later.

    Sincerely appreciate your time and understanding.

  • jhumphr
    jhumphr Posts: 3 New Member

    Thank you for the reply @Jaims .

    I looked into licenses as you suggested, and indeed there were several licences that were all relevant to my Android device. I released them all, and then I uninstalled and reinstalled IDP on my Android device (and I terminated and re-opened the program on my Desktop).

    At the moment I did this, there were now only two licences enabled on my account - one for my Desktop, and one for my laptop (the latter of which has been powered down and unused since long before this problem emerged).

    So, moving on, I did the following:

    1) open IDP on Desktop, and authenticate using Master Password. It still gives me the same pop-up telling me to enter the master password used on a different device. (See first screenshot from my first post).

    2) Reboot Android device, install IDP on Android, open fresh install of IDP on Android.

    3) Sign into my F-Secure on IDP on Android.

    4) Enter a unique (not used before) name for the device.

    5) Generate sync code from Desktop; use it on Android.

    6) Enter Master Password on Android.

    The password is still rejected. I am still stuck on this 'Enter Master Password' page on Android. (See second screenshot from my first post).

  • jhumphr
    jhumphr Posts: 3 New Member

    Hi, in the end I did indeed need to uninstall IDP on all devices, release all device licences, and then install and set up again, in order to fix the issue. I can confirm that the issue does now appear to be resolved (IDP on desktop is no longer prompting me to enter the password used on another device), and I just pray it doesn't happen again!

This discussion has been closed.
Pricing & Product Info