How can I solve the Security Cloud Problem with F-Secure Safe (Mac)

Ektes
Ektes Posts: 6 Explorer

Hello All

After I updated to F-Secure Safe 17.11, an error message comes up with Security Cloud is not available (translated from German). I have followed both solutions from the article https://community.f-secure.com/safe-en/kb/articles/6282-f-secure-product-shows-error-notification-security-cloud-malfunction-on-a-mac-computer, but still get the same error. 

Does anyone know what I can do to solve this problem?

Greetings

Accepted Answer

  • ArthurVal
    ArthurVal Posts: 173 F-Secure Employee
    Answer ✓

    Hi, @Ektes!

    Thanks for reporting the issue! We are currently working on an update to SAFE that will include the potential fix for the issue. I can propose two options how are can proceed:

    1. We can wait for the next SAFE release. Unfortunately, I don't have a clear schedule for the release but it most likely will happen in upcoming weeks (2-3 weeks).
    2. Revert back to the older version of SAFE without an issue. This you can do already now.
      • Remove the current 17.11 version by running the uninstaller located alongside SAFE in Applications directory
      • Login to your account on My F-Secure portal and download the installer. This installer has been reverted to the previous 17.10 version without this issue.

    Best regards, Arthur

    SAFE Mac R&D Team

    Best regards, Arthur

    Mac R&D Team

    EktesLucaseuropaJaimsUkko

Answers

  • Ektes
    Ektes Posts: 6 Explorer

    By the way I just updated Mac OS to version 11.5.1 too.

  • Lucaseuropa
    Lucaseuropa Posts: 303 Rock Star

    Hey @Ektes,


    I've checked this issue internally and it seems that it's being handled right now by SAFE Mac Team.

    We will have more information on that in the upcoming weeks. I will be keeping eye on this and will let you know of any updates here.

    EktesUkko
  • Ektes
    Ektes Posts: 6 Explorer

    I am using the new version F-Secure Safe 18.0 for some days and seems to be solved.

    ArthurVal
Pricing & Product Info