Battery settings on macos big sur

Thomoh
Thomoh Posts: 3 New Member

Fsecure disables the possibility to adjust the battery settings on macos 11

after removing fsecure battery adjustment works fine,

is this known and being addressed?

Accepted Answer

  • ArthurVal
    ArthurVal Posts: 123 F-Secure Employee
    Accepted Answer

    Hello, @Thomoh!

    Are you seeing this behavior on an M1 Mac by any chance?

    We are aware of a similar issue happening on M1 Macs running macOS Big Sur or higher (macOS Monterey).

    Our latest analysis of the issue indicates that SAFE is triggering a bug in System Preferences app that causes Battery preference pane to misbehave like that. We are planning to address this issue in the next SAFE release. But we have a workaround that might help you resolve the issue.

    • Open System Preferences app
    • Navigate to "Sharing" section
    • Click the Lock icon and enter admin password to authorize
    • Go back to the Battery section. It should be working now.
    • Note: The state seems to revert back to broken/unclickable after reboot. So you may need to repeat these steps after reboot

    Could you please try the steps above and share if the situation improves for you? Thanks.


    Best regards, Arthur

    SAFE Mac R&D Team

    Best regards, Arthur

    SAFE Mac R&D Team

    JaimsAmirul

Answers

  • Thomoh
    Thomoh Posts: 3 New Member

    Hi Arthur,

    Thanks for your reply.

    To answer your questions:

    I am running MacOS 11.4 on an Intel I5 macbook pro (early 2015)

    I ran across the problem after I replaced my batteries.

    After reinstallation of F-Secure all worked fine. I rebooted the PC and the battery settings were 'greyed out' again. I applied your workaround and that helped. So back to a workable setup.

    But some homework for you I am afraid. Thanks for helping me out so quickly, confidence fully restored ;)

    Regards,

    Thom

    ArthurVal
  • ArthurVal
    ArthurVal Posts: 123 F-Secure Employee

    @Thomoh, Great to hear it worked out for you!

    It's a bit unexpected that the issue was seen on a non-M1 Mac. So far our internal testing managed to reveal that the issue was specific to Macs on Apple Silicon architecture.

    But good news is that the fix that we are currently working on is universal. So it should fix the issue on both Intel and M1 Macs.

    Unfortunately, I don't yet have a clear schedule for the SAFE release with the fix for this issue. We have a plan to release SAFE 17.11 sometime in August. But that release does not include the fix for this issue.

    But the release right after that one will include it and we'd be happy to hear if it helps you resolve the issue permanently.

    Best regards, Arthur

    SAFE Mac R&D Team

    Best regards, Arthur

    SAFE Mac R&D Team

    Jaims
  • Aldorithmic
    Aldorithmic Posts: 1 New Member

    I have the same problem: all of the user options in System Preferences → Battery are greyed out and unavailable.

    MacBook Pro (13-inch, 2019)

    Intel Core i7

    macOS Big Sur 11.4


    Aldo

  • ArthurVal
    ArthurVal Posts: 123 F-Secure Employee

    Hey, @Aldorithmic

    Could you please try following the steps shared above and share if the issue gets resolved for you?

    Thanks.

    Best regards, Arthur

    SAFE Mac R&D Team

  • Thomoh
    Thomoh Posts: 3 New Member

    Hi Arthur,

    Just installed MacOS 11.5.2 - unspecified update from Apple.

    After the reboot, the battery function works as should be. No need to use the workaround.

    Not sure if this continues to be the case, better check it out.

    Succes!

    Regards, Thom

    ArthurVal
  • ArthurVal
    ArthurVal Posts: 123 F-Secure Employee

    Hey,

    Thanks for letting us know! We'll keep an eye for this issue. We have a fix for the issue which is currently available for our internal testing. It will be included with the next SAFE release.

    Hopefully it'll pin down the last instances of the issue in the wild.

    Best regards, Arthur

    SAFE Mac R&D Team

    Jaims