Annoying popup

Options
Philipgr
Philipgr Posts: 20 Enthusiast
edited January 2022 in F-Secure Internet Security

How do I get rid of this annoying popup that has started to display everyday since last week?


Accepted Answer

  • Simon
    Simon Posts: 2,667 Superuser
    Answer ✓
    Options

    Bearing in mind I'm on the Beta version, so mine might be slightly different, I have this option in Settings, once I have enabled Admin privileges:

    If you can find that, and turn it off, whilst this will potentially compromise your protection, hopefully it might stop the nagging.

Answers

  • Simon
    Simon Posts: 2,667 Superuser
    Options

    Sorry to state the obvious, but have you done what it says?

  • Philipgr
    Philipgr Posts: 20 Enthusiast
    Options

    I have not enabled their Chrome and Firefox plugins because it keeps closing sites that I have used for years. I only enable the banking setting when I do my banking. I leave it switched off because with it on it refuses to open sites that I have been visiting for years. I am tired of having to continuously post false positives.

  • Simon
    Simon Posts: 2,667 Superuser
    Options

    Right, OK, sorry, not sure how to get round that then. I can't access the UI at the moment, but is it possible, perhaps, to disable Browser Protection in the FS Settings?

  • Philipgr
    Philipgr Posts: 20 Enthusiast
    Options

    I have looked but I have not found anything.

  • Ukko
    Ukko Posts: 3,634 Superuser
    Options

    Hello,

    Sorry for my reply.

    Could you try steps like that:

    • "More details..." - on card about Google Chrome extension;
    • Check if there is "do not ask me more" (or so) and dismiss / cancel / skip setting up extension

    If so - can be useful for a while. But after a while it may appear again (if some update / upgrade happens or something unexpected). But should not.

    Also, one note: Banking Protection also with some restrictions when extension is disabled.

    Thanks!

  • Jaims
    Jaims Posts: 846 Former F-Secure Employee
    Options

    Hi @Philipgr

    From your screenshot, you are using F-Secure Internet Security version 18.0 so the steps to disable the notification is quite different. Please note that the features such as Browsing Protection and Banking Protection will not function while the Browsing Protection is turned off.

    To turn off this notification, simply follow the below steps;

    • Open the F-Secure SAFE/Internet Security application
    • Click on More Details on the Action Required section to the right
    • Tick/check the box "Don't Ask Again"
    • Click on Dismiss

    You can always review this by clicking on View All Tasks

    • View Dismissed Tasks (1)
    • Setup (if you wish to enable the browsing protection again)


This discussion has been closed.
Pricing & Product Info