Problem with Banking Protection banner after Windows 10 20H2 update

SystemSystem Posts: 36 Explorer
This discussion was created from comments split from: Windows 10, 20h2! Problems? Wait? Does F-Secure work with it!.

Accepted Answer

  • LucaseuropaLucaseuropa Posts: 266 Moderator
    Accepted Answer

    Dear @radetzky,


    Thank you for your question, I've permitted myself to split your comment from an old discussion and created a new topic for your issue.


    First of all, please do the following:

    1. Open Main F-Secure product view
    2. Choose Settings
    3. Turn Secure browsing  On/Off.
    • If the product has been upgraded, restart the computer and try accessing your online bank again.

    Turn off and on the security features of the product:

    1. Open F-Secure program
    2. Click on Tools
    3. Click on Turn off all security features
    4. Click on Turn on, to activate the program again.

    Check that the Browsing Protection extension is enabled on the browser:

    • If you use Firefox:
      1. Open your browser to check if the browser extension is turned on
      2. Select Add-ons from the menu, then click Extensions
      3. Click Enable next to the Browsing Protection extension
    • If the browsing protection extension is not listed in your browser, you need to reinstall the extension manually:
      1. Open the F-Secure product user interface 
      2. Go to Settings 
      3. Go to the Secure browsing tab and scroll down to the Browser extensions section
      4. If you use Firefox click Reinstall extensions


    Let me know whether you still experience issues with banking protection.

    Thanks!


    Jaimsradetzky

Answers

  • radetzkyradetzky Posts: 7 New Member

    After installing 20H2 problems arised with Bank Security that does not open: tried to reinstall and add again to Firefox but nothing to do.....any help ?

  • radetzkyradetzky Posts: 7 New Member

    Thanks a lot.

    However please take note problem solved only reinstalling ex new after cleaning

    Thank You again !

    Lucaseuropa
Sign In or Register to comment.