Problem installing F-Secure Freedome

Frank_P875 Posts: 3 New Member
edited November 2021 in F-Secure VPN

Based on a good review in Which, I've downloaded F-Secure Freedome VPN on a trial basis.

I still run Windows 7, and don't have any great knowledge of messing about with the system's programming. I've tried to install Freedome and am stuck in a loop where I'm repeatedly asked for admin permissions and given three button options: Restart, Send Error Report and Close. I've tried sending the error report, but am unable to run diagnositcs. If I choose Restart the window momemtarily shows DOS, with the file identified as SYSwow64/cmd.exe. Some code appears to be added, and then the same message with the same three buttons appears.

Does anyone have a solution, please?


Accepted Answer

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee
    Answer ✓

    HI @Frank_P875

    According to the error message, this issue can appear because the F-Secure FREEDOME service is unable to start or has been shutdown by a third-party application. 

    From the Windows Event viewer system logs you can check if the F-Secure FREEDOME service is unable to start. If it is unable to start you should see an event with the ID 7009 and a similar error message: 

    A timeout was reached (45000 milliseconds) while waiting for the Freedome Service service to connect.

    Check if the same error with the event ID 7009 appears for other services. If it appears for other services, there is most likely something wrong with your Windows installation which is causing a lot of service startups to timeout. If that is the case, check if there are any errors related to a faulting hard disk, such as:

    Event ID 7: The device, \Device\Harddisk0\DR0, has a bad block.

    Event ID 153: The IO operation at logical block address 0x8351ca for Disk 0 (PDO name: \Device\00000031) was retried.

    There error messages relate to a faulting hard disk, in which case you should run the Windows chkdsk operation to try to fix any issues related to it.  Please refer this article link here.

    If it only the F-Secure FREEDOME service that timeouts, try to reinstall FREEDOME.


  • Frank_P875
    Frank_P875 Posts: 3 New Member

    Thanks for supplying me with an answer, and apologies for taking a while to get around to doing anything. I've checked my event log and I'm getting nothing for ID 7009, nor for ID153. There are around a dozen error messages from last year with the ID7 code, the last of them in December, but all seemingly related to the CD-Rom. These all predate my installation of Freedome.

    As those didn't seem to be the problem, I deleted Freedome and reinstalled, but am coming up against the same problem. It's made no difference. Do you have any other suggestions, please?

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi @Frank_P875

    This is something we need to check the logfile to find the root causes. For that, you need to contact our F-Secure Support team. However, before that, we would like you to try the following steps to see if that solve the issue as we had received some positive feedbacks from the previous customer's for the similar issue.

    1. Type CMD on Windows search
    2. Right click Command Promt
    3. Choose Run As Administrator
    4. Go to temporary working directory (ie type:  cd C:/Users/<UserName>/Desktop)
    5. Run pnputil -e >list.txt
    6. Open the created list.txt file
    7. Search the file for F-SECURE
    8. Figure out which oem<NUMBER>.inf file is associated with the F-Secure FREEDOME TAP driver
    9. Run  pnputil -d oem<NUMBER>.inf
      • This will remove the driver.
    10. Restart the computer
    11. Reinstall F-secure FREEDOME

  • Frank_P875
    Frank_P875 Posts: 3 New Member

    Thanks for your help. I've followed your instructions and ended up with the same problem anyway. At this stage I've decided I'd prefer to install another VPN rather than continue any further.


This discussion has been closed.
Product & Pricing Info