Italian servers DNS not resolving Apple App Store

OSX_rulezOSX_rulez Posts: 5 New Member

Hello, I've reported this bug to an Italian F-Secure representative and through the Freedome app feedback, but the issue was not resolved.

The Italian Freedome DNS servers do not resolve both iOS and macOS App Store, so when you open the App Store there's an alert "impossible to connect". The odd thing is I can update the installed apps.

If I switch to another EU server it works. This happens since months and it's really annoying. I tried on several iPhones and Mac with different macOS versions.

Please fix it, thank you.

Answers

  • JaimsJaims Posts: 514 Moderator

    Hi @OSX_rulez

    Thanks for bringing this to our attention.

    I was able to reproduce this issue and it has been reported to the relevant team for immediate action.

    Be sure that we will revert with any development as they unfold.

    SethuLucaseuropaOSX_rulez
  • JaimsJaims Posts: 514 Moderator

    Hi @OSX_rulez

    As earlier mentioned that we are already aware of this issue, we have since commenced a formal investigation with Apple.

    We are doing our best to get this rectified as soon as we can but this really depend on how fast we get the response from Apple. We will keep you updated here on any outcome.

    LakshOSX_rulez
  • OSX_rulezOSX_rulez Posts: 5 New Member

    @Jaims Hi, thank you for investigating about the issue. I updated to Freedome 3.3.0.8392 but still I can't access the App Store via your Italian server.

    Why do you think it's an Apple side problem and not of your DNS resolver?

  • JaimsJaims Posts: 514 Moderator

    Hi @OSX_rulez

    Sincere apologies about this issue. You are still unable to access App Store while connected to the Milan node on Freedome VPN because the issue is still pending at Apple's end and there is no resolution yet.

    We will update here once we have a fix.

    Thank you for your patience and understanding.

  • OSX_rulezOSX_rulez Posts: 5 New Member

    @Jaims Hi, I had the same problem a few days ago using the Paris node, but only from macOS (Big Sur) while it was working from the iPhone (but I didn't check if they were connected to the same IP).

  • JaimsJaims Posts: 514 Moderator

    Hi @OSX_rulez

    So far, we do not have such report regarding our Paris node.

    Maybe you would want to double check if it's the same IP address or try to update or reinstall Freedome VPN on the affected device.

  • OSX_rulezOSX_rulez Posts: 5 New Member

    @Jaims Hi, I compared the issue using differents devices, and the problem arises using the server with IP 45.87.186.77 while it works on 159.122.148.5

Sign In or Register to comment.