Firefox and corrupt install

martinkmartink Posts: 402 Adventurer
edited February 11 in F-Secure ID PROTECTION

I have FF 85 and ID 5.0 in Win 10 32 bit

ID is not displaying passwords.

So I uninstall it from Programs and Features. There is no ID Data listed as installed as there once was.

I release the license and download the install package.

I install ID.

I enter the master password. I am not asked to save the recovery image.

The passwords are there in the vault without any furrher action.

My PC does not show up in my account as an installation.

The Browser extension is there without any further action, but it is not activated.

I copy the authorization code and successfully activate the extension.

However, it does not work

I open the ID, the passwords are there.

I uninstall with the uninstall tool.

Reinstall

Now it asks to save the recovery code and name of the PC which is also listed on my account.

I enable the browser extension and successfully activate it.

There is no ID icon at the end of the user ID field of a site which is in the vault.

What else could I try.

Accepted Answer

  • martinkmartink Posts: 402 Adventurer
    Accepted Answer

    The problem with crashing stopped when I took off hardware acceleration.

    Now it may be more than a day between crashes and mostly it is Facebook tab that crashes when I go far back.

    LinkedIn still has the problem occasionally. It has worked properly as well.

    So my issues brought up in this thread are more or less solved for now on my PC.

    Ie. thorough uninstall and fresh install and no hw acceleration.

    Laksh

Answers

  • martinkmartink Posts: 402 Adventurer

    I have the same problem intermittently with ID 5.0 and Firefox 85

  • K_PK_P Posts: 35 Explorer

    Hi,

    Also, system autofill functionality no longer works (Firefox 85.0.1, Windows 10 Pro 64bit).

    System autofill seems to work ok with Edge, but fails also with Chrome at the same system. Both browsers running latest version.

  • LucaseuropaLucaseuropa Posts: 302 Moderator

    Dear @martink and @K_P


    Thank you guys for your input.

    I do confirm that this issue is being investigated right now.

    I will inform you about the progress in this thread.


    Thank you for your patience and understanding.

  • SethuSethu Posts: 720 F-Secure Employee
    edited February 11

    Hi @martink

    Thank you for the screen shot and detailed information, may I ask you try uninstall and re-install the Firefox browser?

    Did you check with other browser i.e Chrome browser?

    Based on the screenshot, I would like you to double check if you have saved the data in correct format. For example, if you have google.com in key entry and the login url is mail.google.com, those do not match. The other example, if the google.com is missing https:// prefix which also causes mismatch. That can be also seen that the entry's url is not a clickable link. It's a security feature to force url links to have the protocol part defined for them to become usable. Please ensure the saved data should be in correct format i.e https://my.f-secure.com on your IDP.

  • zuuhis79zuuhis79 Posts: 17 Explorer

    There are multiple threads on this. Apparently the requirement for http:// or https:// on a password URL changed on last update because of "security reasons". Which is quite odd considering that entries with https:// prefix work on pages that were opened with only http:// prefix (or vice versa, entry with http:// prefix and page opened with https:// prefix), so no extra security in there.

    Hopefully this will soon be fixed and one can only hope that when they make major changes in future releases for password entry requirements, they remember to tell it to customers.

    Ukko
  • martinkmartink Posts: 402 Adventurer

    Thank you for your responses.

    This time I did uninstall the hard way.

    Normally I use portable Firefox in private mode.

    In order to to do a proper uninstall I installed the normal version.

    Then I uninstalled with Revouninstaller using moderate scan and deleteing leftover files.

    Then used F-Secure uninstall tool to uninstall F-S ID and user data.

    Copied a fresh Firefox portable folder.

    Added browsing protection.

    Installed F-S ID , enable Firefox extension, enable browser autofill and activated it.

    Added http:// to saved URLS

    Then this far mixed results (in in portable private Firefox)

    On a couple of pages No matching results

    On a couple of pages just blanck box

    One page ID provided the login and log in was successful.

    Will be watching how it goes in the future.

    SethuUkkozuuhis79
  • PeteTheNorwegianPeteTheNorwegian Posts: 1 New Member

    Hello, world! I may be experiencing the same issue K_P has, but not sure if it's exactly the same.

    When using the ID Protection autofill add-on in both Firefox and Chrome, the autofill says "No matching entries". I noticed this by accident, but it hasn't been an issue before, so it should be from one of the latest updates to the software.

    I found that a solution was to add "https://" to all the links inside of ID Protection for Windows, but I'd rather not have to go through all my entries and edit these. Is a possible solution here, for the next update, to automatically add "https://" to all links automatically? It doesn't make sense for end customers having to add "https://" when entering a web address - it's not customer friendly.

    See attached picture for explanation.

    Hope this can be resolved soon. :)


    Ukko
  • zuuhis79zuuhis79 Posts: 17 Explorer

    Apparently the functionality of previous version will be reverted in next version, so you don't need to add https:// or http:// prefixes to URLs. There is no info on when this will happen, so it might be a few weeks or a few months.

    Ukko
  • SethuSethu Posts: 720 F-Secure Employee

    Hi @martink

    We have recently released a latest version of KEY/IDP PC browser extension 5.0.42 for both Firefox and Chrome. It fixes the login form submitting problems and many other issues. You can uninstall and re-install the extension and check if the issue still reproduce.

  • martinkmartink Posts: 402 Adventurer

    Thanks @Sethu

    I do have now 5.0.42

    However, what I described above did solve most of my problems.

    I still have some

    Sometimes when Firefox crashes I have to copy and paste the activation code again.

    With LinkedIn my bookmark opens a page where the password is displayed. If I hide it and get the password from F-S ID I don't get logged in. Only when the password is displayed.

    But I can live with those.

    Sethu
  • SystemSystem Posts: 39 Explorer
    This discussion was created from comments split from: No credential options available on any login form.
  • JaimsJaims Posts: 573 Moderator

    Hi @martink

    We have merged comments, from the other posts, here because they are the same issue and it is much easier to follow from the same thread.

    I was not able to reproduce the issue you mentioned about LinkedIn and I tested this on Edge, Firefox and Chrome and they all responded well. I will recommend you also try on multiple browsers so we can narrow down the issue.

    Regarding Firefox crashing, can I recommend you getting the latest version 86.0.1 or simply reinstall to prevent frequent crashing and the focus can be on the overall performance of ID Protection on the said browser?

    LucaseuropaUkko
This discussion has been closed.