FS ID Guardian PC 5.0 beta 14 upgrade removed FS Protection

CaleCale Posts: 113 F-Secure Product Manager

Due to a bug in a new packaging we took into use in the ID Guardian beta 14, the latest channel upgrade removes FS Protection from your device.

We stopped the channel upgrade as soon as we noticed this, but few upgrades managed to went through.

If you received the ID Guardian beta 14, you don't have FS Protection anymore and the beta 14 won't install future upgrades.

(You can check you ID Guardian version by right-clicking the system tray icon and selecting About.)

Do not reinstall FS Protection, but perform the following steps:

  1. Download and run uninstallation tool from here: https://download.sp.f-secure.com/uninstallationtool/FsUninstallationTool.exe
  2. Choose 'Select what to remove' and check "F-Secure security product" and "fs id guardian".
  3. Click Next and restart your PC.
  4. Log into 'My FS Protection' portal: https://safeavenue-tp.sp.f-secure.com/iframe/-sso/fs_protection/?lang=en
  5. Now you can re-install fs protection and id guardian.

We humbly apologize for this mishap. The beta program has always been very stable and we haven't had this unrecoverable issue before.

-Cale

Ukko

Answers

  • martinkmartink Posts: 393 Adventurer

    Certainly took me by surprise. Defender was giving me alerts

    Clicking the Open fs protection gives


    That is as far as it goes.

    If I look at the installed progs

    It is not there any more. (but the fs ID beta 14 sure is)

    When I tried reinstall before reading this post something always went wrong and I was asked to reboot. No number of reboots solved the install problem, but they removed the Defender alert

    Have not tried the proposed solution, but expect that to work. The downside is that Freedome will be removed as well if the tool works as before.

    NOTE

    This problem occurs with FS ID Guardian beta 14.

    If you have FS ID protection (the GA normal version) you are safe.

  • martinkmartink Posts: 393 Adventurer

    The current uninstall tool has the option to select the items

    Next will open a list of the FS items that can be selected for uninstall and with some also status "Found"

    When FS Protection was removed you do not have the icon in systray

    See also the red alert on Defender icon.

    Before the problem and after reinstall the FS Protection icon is there.

    No the FS ID icon is there, too.

Sign In or Register to comment.