Error: The app could not be configured. Restart Freedome and try again?

WilsonEvans Posts: 1 New Member

While opening FSecure Freedome at startup I get the above error message "App can't be configurated. Starte Freedome again and try again. But anytime I do this the same error message appears.

Any idea where the bug is?

Any help is appreciated

Thank you


  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hello @WilsonEvans and welcome to F-Secure Community! 👋

    Firstly, could you please specify on which device occurs the described problem?

  • Tommy600
    Tommy600 Posts: 18 Explorer
    edited January 2021

    I have also had this once or twice on an iPhone. Over the past few releases Freedome has become a bit rubbish. It constantly disconnects at every other page when I try to load a webpage on iOS if the phone has been in sleep, and on my mac it takes ages to connect four out of five times. On wired or wifi connections. It always used to happen but it is far worse over the past few months. All you get is the loading rainbow. Connecting forever. Turning the VPN off and on fixes it. I have tried on different connections too and it also happened on my old machine. Other VPNs connect instantly, sadly after four or five years using f-secure products I have moved to another VPN. I am sorry but you need to fix your problems. If other VPNs can connect almost instantly, why not Freedome? I will try again in a few releases, for now I must use another VPN.

This discussion has been closed.
Product & Pricing Info