DNS is not accessible when Freedome is ON

jdmurrayjdmurray Posts: 9 Observer

Since updating to 2.34.6377.0 on Windows 10, DNS stopped being reachable when Freedome is ON. No web pages will load and nslookup only returns a "DNS request timed out." DNS is accessible immediate after Freedome is OFF. The only way I have been able to "fix" this issue is by uninstalling and reinstalling Freedome and reapplying my subscription code. However, once I exit and re-enter Freedome, the DNS issue reoccurs.

Best Answers

  • SethuSethu Posts: 644 Moderator
    Accepted Answer

    Hi @jdmurray

    Have you tried to select different virtual location and check again? and did you check disable all Freedome feature and check again? i.e Browsing Protection, Tracking Protection

    If yes, but the issue still remain, you can perform the following steps.

    On your Windows 10, open command prompt as an administrator and type the following commands one by one:

    1. ipconfig /flushdns

    2. netsh winsock reset

    3. netsh int ipv6 reset

    After that, restart your machine.

    Once your PC is rebooted, you will then clear your browser cache and check your website again.

    jdmurray

Answers

  • jdmurrayjdmurray Posts: 9 Observer

    Yes, I have tried disabling all of Freedome's features and selecting different POPs without success. However, the reset commands you gave seem to have fixed my problem. I still maintain DNS service even after restarting Freedome. I'll let you know if DNS stops working again and what might have happened to mess up my stack.

    Thank you very much!

    Sethu
  • _Nick__Nick_ Posts: 6 Observer

    Slight correction to the above...

    When the batch file is created, you'll need to right-click and 'Run as Administrator'. Alternatively, create a shortcut to the batch file and in the properties of the shortcut, check the box to run as administrator

  • jdmurrayjdmurray Posts: 9 Observer

    Yes, thanks for the non-rebooting workaround. Now I only need to disable FreedomeVPNConnection after starting Freedome and let Freedome re-enable the interface, after which DNS service connectivity is restored. This need appeared with 2.34.6377.0 and I'm hoping this issue will be fixed in the next Freedome update.

  • _Nick__Nick_ Posts: 6 Observer

    New version was released yesterday - v2.36.6554.0...but it looks like the same issue persists. ;-(

  • jdmurrayjdmurray Posts: 9 Observer

    I was thinking that there must be something with the particular configuration of my Windows 10 that is causing this DNS problem in Freedome. I do use the program O&O ShutUp10 to tweak my Windows 10 configuration to disable unneeded features and keep Windows 10 from reporting metrics on everything I do--including sending my Freedome VPN IP address to Microsoft.

    I used O&O ShutUp10 to revert my Windows 10 settings back to factory default, rebooted, started Freedome 2.34.6377.0, and DNS worked perfectly as it had before. (DNS also remained working with the 2.36.6554.0 update.) Now I just need to experiment with O&O ShutUp10 to determine which setting conflicts with Freedome. Stay tuned...

  • jdmurrayjdmurray Posts: 9 Observer

    I have perform quite a bit of experimentation using O&O ShutUp10 versions 1.8.1412.246 (Jun 2020) and 1.8.1415 (Oct 2020) and using it have been unable to recreate the condition(s) that disabled DNS connectivity in Freedome  2.34.6377.0. I am now using much more restrictive settings in O&O ShutUp10 (Action = "Recommended and somewhat recommended settings") than I was previously and Freedome is working fine. It may be, rather than causing it, O&O ShutUp10 inadvertently fixed the problem in my Windows 10 that prevented Freedome from accessing DNS.

  • JaimsJaims Posts: 397 Moderator

    Hi @jdmurray @_Nick_

    I have tried to reproduce this issue on Freedome version 2.36.6554.0 but to no avail.

    Kindly update to this version from the F-Secure Freedome VPN application by clicking on Help - About Freedome - Check for Updates and then try to reproduce this issue again?

    Do let us know the outcome.

  • _Nick__Nick_ Posts: 6 Observer
    edited October 22

    Jaims

    You'll see from my comment on Oct 8th above that I have already done this and the issue persists.

    I have opened a new ticket (first support person took down my email address incorrectly) and provided various logs. Ticket 03xxxxx

    Nick

    EDIT: Removed PII

  • _Nick__Nick_ Posts: 6 Observer

    Issue now resolved for me after working withe F-Secure support.

    I had an old and known problematic version of npcap installed (v0.994). This comes bundled with Wireshark. Uninstalled it, rebooted and all the Freedome DNS issues were resolved.

  • jdmurrayjdmurray Posts: 9 Observer

    I'm currently using Wireshark 3.2.7 with Npcap 0.9997 and my Freedome DNS is still working fine. I just updated to Npcap 1.0 and DNS connectivity broke again until I used the "netsh interface set interface FreedomeVPNConnection disable" command and Freedome re-enabled the interface. Now Freedome's DNS access is good even when I restart Freedome.

    At least we know the source of this problem and how to "fix" it.

  • SethuSethu Posts: 644 Moderator
    edited October 16

    Hi @jdmurray

    We have released a newer version of Freedome v2.36.6555.0, sometime the Check for Update option not get latest version, as such you need to download our latest version from here , and install it on top of existing Freedome to upgrade the latest version. You will then check if the issue still reproduce.

    Laksh
  • jdmurrayjdmurray Posts: 9 Observer

    @Sethu

    I downloaded and installed Freedome v2.36.6555.0 and kept Npcap 1.0 installed. The Freedome DNS connectivity still worked after (re-)starting Freedome. I'll post back here if anything breaks again.

    Laksh
Sign In or Register to comment.