F-Secure block steam game "Iron harvest 1920"

zeitdiebzeitdieb Posts: 1 New Member

I use the newest version F-Secure Safe 17.8 with Windows 8.1 64bit and Steam.

When i want to start the game "iron Harvest 1920" ins tem the message pop up: "Application load error 3:0000065434"

The game wont start.

I have steam checked the game on the drive: its ok.

When i deactivated F-Secure: the game runs well!😑

When i activate F-Secure the error will be prompted.😑

=> So it seems that F-Secure blocks the game: but no message in F-Secure will pop up.


With Kaspersky-AV before i had not these problems.


When i tell F-Secure to lock out / ignore the game directory it will work.

But this method seems to be not perfect

Answers

  • SimonSimon Posts: 2,605 Superuser

    Not sure it will make any difference but are you aware FS has a Gaming Mode, available from the system tray icon? Might be worth a try?

  • VilleVille Posts: 494 F-Secure Employee

    Hi,

    This typically happens because DeepGuard is monitoring the game. Some games really don't like when that happens (it injects a small bit of code into them and it causes their cheat-monitoring or similar feature to trigger). We generally avoid doing this to Steam games, but in this case, the avoidance didn't clearly work. As we don't block the game from our side, we don't show any flyer about it. The best option is to submit it as false positive and write to description that it doesn't run when protection is enabled and we can fix it from our side.

    The other option is, like you said, exclude the directory where the game is, to make DeepGuard also ignore it.

    Ville

    (F-Secure R&D)

    JaimsUkko
Sign In or Register to comment.