F-Secure Antivirus Installation Failure

HenfreHenfre Posts: 5
edited September 10 in F-Secure SAFE

Hello,

I'm running the standard F-Secure AntiVirus installer. However, as soon as I choose to install, I get a message "Something Went Wrong". It suggests that I reboot and try again, but to no avail.

I happened to find this message in a log file that appears to be related to this application at:

C:\ProgramData\F-Secure\Log\OneClient\NetworkInstaller

Message:

CcfDownload::File::WriteData: WriteFile(C:\Users\USER\AppData\Local\F-Secure\NetworkInstallerTemp\fs471637180.tmp\sidegrade.zip) failed: [6] The handle is invalid.

I can see that it's trying to download the file at:

The file downloads just fine in my web browser. I don't understand why the installation is failing.

Any help would be very much appreciated!

Ukko

Best Answers

  • HenfreHenfre Posts: 5
    Accepted Answer

    I found the solution!

    All I had to do was have someone else press the install button and it worked. Naturally, it works if you try to show someone the problem.

    Who knows. It is a mystery ~

    Ukko
  • VilleVille Posts: 494 F-Secure Employee
    Accepted Answer

    There was a very elusive server side problem that affected only a small portion of users. It was fixed yesterday. Sorry for the trouble.

    Ville

    (F-Secure R&D)

    HenfreUkko

Answers

  • SimonSimon Posts: 2,610 Superuser

    Maybe its an old installer? Where are you downloading the installer from?

    Ukko
  • HenfreHenfre Posts: 5
    edited August 23

    Nice idea, but the installer is current. I downloaded it from this link yesterday:

    This is the same link coming from the download page:

    I'm choosing to attach the full installer log file in case this helps. This computer is two days old and has never had any antivirus software installed besides Windows Defender. Just to be sure, I ran the F-Secure removal tool and McAfee removal tools.

    Ukko
  • JOnesJOnes Posts: 263 Active Engager

    Suggestion:

    Have you checked that all possible windows updates been run into your "brand new" pc/laptop?,installation may fail due to missing certain windows security issues...

    Ukko
  • HenfreHenfre Posts: 5
    edited August 23

    Great idea! I did just check for updates, and I was missing an update for edge. I installed that, rebooted, same error.

    I checked for updates again just to be sure, and we are all up to date! It doesn't seem to be a missing update, or if it's missing one, it isn't telling me.

    Ukko
  • SimonSimon Posts: 2,610 Superuser

    The only other thing I can suggest is that you run the uninstall tool (even though FSAV isn't installed), to clean up any previously attempted installation debris, reboot, and try the installer again. You can get the uninstall tool here:

    Failing that, a word with Support might be your best option.

    Ukko
  • HenfreHenfre Posts: 5

    I gave the tool a go again, but I'm still getting the same error after.

    I'm going to follow up with F-Secure, and if we figure it out, I'll come back here and post the solution.

    Ukko
  • SimonSimon Posts: 2,610 Superuser

    That would be good. 🙂

    Ukko
Sign In or Register to comment.