connection problem

Freedome works fine with both of my Android devices and all three of my iOS devices. Beginning recently, it stopped working with both of my Windows 10 devices. At first, Freedome would not install. With what appears to be a recent reconfiguration of the installer, Freedome now installs but continually shows a "Connecting ON" status. While Freedome is in this "Connecting ON" status, both of my Windows 10 devices cannot communicate outside my LAN (i.e., with the internet).

Comments

  • SethuSethu Posts: 636 Moderator

    HI @crazzyking

    On Windows, the killswitch feature is turned OFF by default. Please check if automatic killswitch is enabled. Here's how to check.

    1. Open F-Secure FREEDOME VPN
    2. Click Settings

    The automatic killswitch is the 4th button under Connection & Status. If it is turned on,

    1. Click Allow connections to other devices in trusted networks
    2. Check the network you're currently connected to
    3. Click Save.

    If issue remain, please ensure that your internet connection is stable. If possible, connect to some other network to see if the issue continues. If there is no issue with your home router, please perform the following instructions.

    Open the command prompt as an administrator. Click the Windows start button > Type "cmd" > Right-click Command Prompt > Click Run as Administrator.

    In the Command prompt, type the command below. After each command, press Enter to execute.

    ipconfig /flushdns

    netsh winsock reset

    netsh int ipv6 reset

    You can now restart your machine and check again.

    In case the issue still continues also when you're connected to home network, try removing and reinstalling F-Secure FREEDOME VPN on your device.

    Jaims
Sign In or Register to comment.