XFENCEDaemon using a lot of CPU (MacOS Mojave)

Today I checked Activity Monitor why my computer – MacBook Pro running MacOS Mojave 10.14.6 with F-Secure SAFE 17.8 – was suddenly getting hotter. The CPU usage of XFENCEDaemon is constantly between 40-60 %, taking the 1st position on the process list, while all other processes are mostly under 2 % (only browser is open). Rebooting the machine makes no difference.

What's going on? Is there any way to make XFence use less CPU?

Best Answers

Answers

  • SmallHollowSmallHollow Posts: 3 New Member

    Thanks for this solution! MongoDB and F-Secure XFENCEDaemon now co-exist peacefully on my computer!

    ArthurVal
  • daosdaos Posts: 4 New Member

    How is the exception line produced? I run into the same problem but during development of a clojure project. Please don't ask me to provide a path, I can't keep asking here every time this XFENCE tool needs an exception.

  • daosdaos Posts: 4 New Member

    Nevermind, option-clicking the F-Secure icon in the menu bar reveals "Configure DeepGuard" option, I'll play around with that.

  • daosdaos Posts: 4 New Member

    For comparison; Compiling a simple Clojure "uberjar" with F-Secure SAFE with real-time scanning and DeepGuard enabled took me 345 seconds. After uninstall of F-Secure SAFE, the same compilation took 17 seconds.

    Ignoring the fact I have a powerful laptop, the difference is x20 in time. I didn't see any difference after disabling real-time scanning in the system preferences F-Secure plugin, nor did I manage to create a ruleset in the DeepGuard configuration interface to get the same speedup (in fact, I had no speedup whatever I put in the DeepGuard rule set).

  • ArthurValArthurVal Posts: 61 F-Secure Employee

    Hello, @daos!

    Please note that after adding a rule to DeepGuard Configuration app, you need to close it or press Command+R to apply the rule changes to DeepGuard service (XFENCEDaemon). The rules will be applied when the configuration app is closed too. Could you please share if the issue with slowdown goes away after applying rule changes? Thanks.

    Best regards, Arthur

    SAFE Mac R&D Team


  • daosdaos Posts: 4 New Member

    Yes, I did that (picked reload from menu), but there was no change in used time. My best guess is that I didn't manage to set the correct exclusion rules, but I tried basically any wide combination of all processes, all parents and all paths.

    As I'm probably misconfiguring DeepGuard, can you please point me to appropriate documentation on this interface?

  • ArthurValArthurVal Posts: 61 F-Secure Employee

    Yes. It seems that the created rule does not cover the file access that DeepGuard is intercepting. DeepGuard feature is not deployed to production in its full potential yet. As in, the service itself is operational, its main goal is to collect diagnostics to perform proper decisions in the future. But its UI and Configuration interface are still in development, thus there is no official documentation on user facing controls.

    We would need SAFE diagnostics from that machine to properly investigate this on our side. Please run the Support Tool app shipped with SAFE and share the resulted archive with SAFE diagnostics with our support at https://www.f-secure.com/en/home/support/contact. Thanks.

    Best regards, Arthur


Sign In or Register to comment.