FSCSAFEADMIND: Cannot connect to kext with name: FSCNKE, retrying in 1 second(s)

Latest Mac OS Catalina release (10.15.5) shows in Console the following error (every second):

Cannot connect to kext with name: FSCNKE, retrying in 1 second(s)



Any idea how to get rid of these messages?


Thx in advance!


John

Tagged:

Active · Last Updated

Answers

  • jameschjamesch Posts: 132

    Hi John

    Can you please advise which product is this related to ?

    SAFE does not have fsnke as it is current used for firewall in corporate products (this is what user is experiencing). We can probably remove this message. Please create a support ticket and we will fix it in the next release.

  • JACOJOJACOJO Posts: 5
    edited May 27

    I'm using FSecure Safe by XS4all (This Dutch ISP provides F Secure Safe to its customers) on a MacBook Pro 16 inch, OS Catalina 10.15.5.

    Searching your website I cannot find a way to submit a support ticket ;-)

  • JaimsJaims Posts: 353

    Hi @JACOJO

    F-Secure SAFE by XS4all is a modified version of our product and XS4all are in better position to assist with the first level troubleshooting.

    Kindly contact them and they will do the needful.

    Thank you.

    Sethu
  • JACOJOJACOJO Posts: 5
    edited June 2

    They (XS4all) advised to uninstall and reinstall using their F-Secure software, but the problem persists :-(

    See screenshot below: kext file is missing... this is definitely a missing file during installation

  • JACOJOJACOJO Posts: 5
  • JaimsJaims Posts: 353

    Hi @JACOJO

    Looks like something to do with the kernel driver and might need to get through Recovery Mode and run some commands but there would be a need to send your ISP (XS4all) the fisdiag log so we can ascertain the exact root cause. So, I still recommend you contact them highlighting that reinstallation has not solved the problem.

    You need to provide them with the log file and the interface screenshot of the your F-Secure Safe by XS4all, they know exactly what to do afterwards.

    DawidFS
  • Will_Will_ Posts: 3

    Having the same issue here, also with the XS4ALL version (latest version, on latest production MacOS). Quite annoying how it spams the console.

  • ArthurValArthurVal Posts: 19

    Hello, @Will_!

    This issue with printing our this error message has been solved in SAFE for Mac 17.8. It does not indicate any issue with SAFE functionality. This message just informs that SAFE cannot connect to a service that is not in use. It is primarily used in corporate products provided by F-Secure. You can contact XS4ALL to request the status of the update to the latest version of SAFE available to F-Secure partners.

    Best regards, Arthur

    SAFE Mac R&D Team


    Jaims
Sign In or Register to comment.