Freedome blocks Internet

I've had problems for a couple of days with not being able to connect to intenet either thriu WiFi or cable. I have tried with other computers and haven't had any problems. I'm running Windows 10.

When i choose my network it connects ok but with a message that I dont have any internet as i have other PC:s paralel to this one I can see that i have Internet on these.

After testing a lot of things I started thinking about Freedome so i check out if the service was running and yes it was. So I tried to stop it and immediately I got internet.

This is not what I expected.

How should do to be able to use Freedome and Internet at the same time? I think thnats the whole idea with freesdom?

Best Answer

  • JaimsJaims Posts: 368 Moderator
    Accepted Answer

    Hi @LarBel

    Try to enable KillSwitch feature on that device if you are still facing this issue.

    • Open Freedome
    • Click Settings

    The automatic killswitch is the 4th button under Connection & Status. If it is turned on,

    • Click Allow connections to other devices in trusted networks
    • Tick the network you're currently connected to
    • Click Save

    Let us know if this works for you.

Sign In or Register to comment.