Slow performance (speed/latency/blockages) on all servers

Hello,

 

For the last few months I've experienced very poor performance using Freedome; on the server located in my home country and on the several overseas servers I have tried.

 

My home hardware is Huawei re-branded ADSL router/modem in pass through mode, to Unifi Ubiquiti router, switch and wireless access points. Performance without Freedome switch on is good across all devices on my network, pages, youtube etc all work fast and responsively. On SpeedTest.net my results are reasonably close to the expected maximums my ISP offers at 69Mbps down, 19Mbps up, 9ms ping. Via the Google speedtest I get 63Mbps down, 17Mbps up, 11ms ping.

 

When I switch on Freedome, performance is noticably worse. I can't get Speedtest.net to work at all, it registers a ping speed of 11ms, but fails to upload or download anything and gives me am error:

 

"A socket error occurred during the download test. A firewall could be blocking the connection or the server might be having some issues. Please try again later.".

 

Running a speedtest via Google offers 53Mbps down, 17Mbps up - this seems pretty reasonable for a VPN connection. Unfortunately, the overall web-browsing performance is very poor, especially noticable on complex sites, youtube, video sharing. For example, it might take 20 seconds for the video thumbnails on a page to load; or videos might stream poorly with buffering or reversion to lower quality.

 

It feels like a latency issue, or that some aspect of my connection is blocked and less efficient protocols are having to be used; or maybe default methods aren't working, are timing out, and websites are then trying a different approach. It is clear from Google speed test that freedome is offering my a reasonable speed for 40mb file download/upload - but there is some other issue causing me problems.

 

The fact that SpeedTest.net doesn't work for me at all is perhaps most telling. I'm not aware that I have changed my firewall settings. But am nonetheless unclear why my performance could be great without freedome; but then connecting via freedome causes problems. 

 

Things I have tried so far:

- Different freedome virtual locations.

- Testing from work/friends houses.

- DNS Flush

- Uninstalling and reinstalling the freedome application.

 

I'd be very grateful for any advice that would help me return to a full-speed experience. As I said, Freedome previously worked wonderfully for me, but the last few months have been bad.

 

Thanks!

This discussion has been closed.